Support » Plugin: BackWPup - WordPress Backup Plugin » Brand new default installation doesn't work.

  • Resolved rboyz

    (@rboyz)


    Hi, I’ve been waiting for the 3.x release as I couldn’t get BackWPup to work with WP 3.51.

    Regrettably, it doesn’t work – all I get is the status bar at the top saying ‘Job “<job name>” has started’

    but nothing happens and there are no logs.

    So, to test I created a brand new default installation of WP 3.51, on a different hosting provider, installed backWPup, and it does exactly the same thing — that is, pretty much nothing.

    I really can’t wait any longer — of course this is a free plugin and you owe me nothing, but I really don’t want to just leave either.

    Surely, this should work with a standard plain-vanilla install of WP 3.51? Is there not a debug setting or anything so that I can see why it’s failing?

    Thanks!

    http://wordpress.org/extend/plugins/backwpup/

Viewing 7 replies - 1 through 7 (of 7 total)
  • rboyz

    (@rboyz)

    OK, I finally got an update to start by using the “start job with a link” mechanism. The only problem is it runs forever, unless none of the boxes are checked in the tasks list.

    rboyz

    (@rboyz)

    And now, I’ve managed to get it working, by disabling the “Restart the job on every main step on a working job” setting.

    Since the default settings had that turned on, I only found that by chance (it was a guess this might be the problem because the job would always stall after the first step).

    I might still have a problem with wp-cron, but my guess is that’s a service-provider problem, and hopefully I can work around that with either a cron job making a call to wp-cron or the “with a link” schedule start setting. I’ll leave it set as a scheduled backup overnight and see if it works — if not, I’ll try setting up a cron job as said.

    Of course, the problem isn’t really resolved because not being able to kick off the restarts may mean I run into problems with larger backups — but I’m done investigating for now.

    Thanks for the plugin — I submit the above as it may help with your diagnosis and/or help you to improve the documentation.

    rboyz

    (@rboyz)

    Ok, next update … scheduled backup overnight didn’t work, but a call to http://websitename/wp-cron.php did.

    I’ll create a cron job to call that url and see if that does the job.

    Plugin Author Daniel Hüsken

    (@danielhuesken)

    Hello i have added a additonl Test bevor the job starts in the next release. I hope with it we can find mor information why it not starts.

    rboyz

    (@rboyz)

    HI, I’ve installed 3.0.4, I think it is working with the wp-cron, but want to leave it overnight to see. The blog doesn’t get a lot of traffic, but it worked with a call to wp-cron.php, so I’m expecting it to work with site traffic as well — just have to wait and see.

    Thanks for the test — when I try “run now” I get this:

    The HTTP response test get a error “couldn’t connect to host”The HTTP response test get a false http status ()

    Ihr Englisch ist aber sehr gut … wenigstens besser als mein Deutsch!

    rboyz

    (@rboyz)

    Ok, that ran overnight on wp-cron, so other than performing a test-restore, I’m done testing until I roll out to other blogs.

    Thanks for your help Daniel — if you want me to test anything else, please let me know — as you know, I’m still having a trouble with the “run now” which gives the response

    “couldn’t connect to host”The HTTP response test get a false http status ()

    but I can get around that on the rare occasion I need to by having a second job that is set to use the nonce call, or just temporarily setting the schedule on this job to that.

    Thanks again — if you want to mark this as resolved, feel free — I can always raise another thread later if necessary.

    Caspar Hübinger

    (@glueckpress)

    Hi rboyz,

    thanks so much for offering testing support, it’s highly appreciated! We’re still fixing a couple of issues, might contact you later this week. Thanks again!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Brand new default installation doesn't work.’ is closed to new replies.