Support » Plugins and Hacks » [Resolved] BPS Dashboard Options Page Won't Open

[Resolved] BPS Dashboard Options Page Won't Open

  • Hello,

    This is the story of what brings me here:

    I wanted to have G+ comments on my blog, so I downloaded Comments Evolved for WordPress plugin. It led me to install Php 5.3 + because my previous configuration was at 5.2, which was not compatible with this plugin.

    So I upgraded to 5.4 (single.ini) with my host, Bluehost.

    Php.ini file was created by Bluehost, and it wrote the php handler information into the public .htaccess file that already existed which BPS had created.

    I took the handler info from the top, deleted it and placed it under custom code in BPS to do the process over again.

    Problem: When creating the secure htaccess file for WP-Admin, BPS times out (although it creates the file as I see it through FTP).

    From this point forward, I cannot access BPS options through dashboard unless I remove the PHP handler information from the htaccess in my public Root…which consequentially makes Comments Evolved to stop working and remind me that it doesn’t detect php 5.3.

    This is all very confusing to me and trust me I’ve searched and spent hours trying to find the right information.

    The same thing happens if I have bluehost create a php 5.3 or cgi single.ini….makes no difference. same symptoms.

    Any help is appreciated? I need to know how this is all related…but the above is all fact.

    Thank you!


Viewing 15 replies - 1 through 15 (of 56 total)
  • Plugin Author AITpro


    Ok let’s narrow down the possible problems to zero in on the exact cause.

    Activate BPS Default Mode and add your 5.4 php/php.ini handler .htaccess code directly into the default .htaccess file using the BPS built-in .htaccess editor. You will be editing the “Your Current Root htaccess File”, which will be a standard/default WordPress .htaccess file/code. Let me know the results at this point. If you are forced to do these steps via FTP then do them with FTP just to get to this point of testing.

    # The DEFAULT .HTACCESS file should be used for testing and troubleshooting purposes only
    add your php/php.ini handler .htaccess code here.
    Plugin Author AITpro


    Also post the php/php.ini handler .htaccess code that you are using.

    Plugin Author AITpro


    Also doing a general search I found a very similar situation/problem.


    The problem and solution could be something as simple as this:

    I know that at Bluehost when you change the phpConfig that it will modify the .htaccess file in your main public_html folder.

    If this WordPress that you want to change is in a sub-folder, it might have it’s own .htaccess that’s causing it to not use the main one. Try to find the line of code in your main .htaccess for php 5.3 and copy it to the .htaccess where your WordPress is located.

    Thank you AITpro. I already came across the link you sent and in this case it doesn’t apply. I don’t have multiple htaccesses/subfolders, just one site with this installation.

    The handler code that I am using right now is:

    AddHandler application/x-httpd-php54s .php

    That is the code that Bluehost puts atop the root htaccess file, which is probably the same as if I were to go through the custon code option within BPS…but I go through the custom code route through BPS anyway. Either way, I have tried both, and as long as that handler is in the htaccess, the BPS options will not open and time out in I believe a 1001 error.

    Another consequence of this PHP upgrade has been that my WP cron is not functioning. Scheduled posts were missed since this and now I have to do publish manually, which has led me to find temp solutions, namely an wpconfig alternative cron configuration which I have not yet tried.

    Let me do the first step you mentioned and I will repost. I will remove the handler through FTP to be able to access BPS options through WP dashboard, then active default and follow your steps.

    BTW before coming on here I talked to Bluehost about this. They said PHP 5.4 single ini should be fine and it is actually where they are moving their customers to, but they couldn’t tell me what the relation is between BPS, the PHP upgrade and perhaps the new commenting system.

    Plugin Author AITpro


    Hmm interesting that there is some sort of timeout occurring. We have tested BPS up to PHP 6.0 and the PHP5.4 version we are currently testing with is PHP Version 5.4.7. So to answer your question there should not be any sort of incompatibility issue with BPS using PHP5.2.x, PHP5.3.x, PHP5.4.x or up to version PHP6.

    Plugin Author AITpro


    Also to ensure that another plugin is not actually causing this problem then what you want to do is deactivate all other plugins and then see if BPS functions normally. Unfortunately, a very common problem that we see is some plugins load their scripts everywhere in the WordPress admin area – other plugin settings pages, WordPress settings pages, everywhere. 😉

    @ait Good to know. I am sure BPS works with these PHP versions, but I am here for help because I don’t know how all of this is related.

    I haven’t tried disabling plugins just yet. I tried the first step you mentioned:

    FTP’ed into root htaccess, removed php handler information so that I could access BPS options through WP dashboard.

    I also renamed php.ini to php.ini.bak (the php 5.4 ini Bluehost created)

    Went to BPS options, created a default root htaccess, went to built-in editor and added handler so that it now appears like this:

    AddHandler application/x-httpd-php54s .php
    # If you edit the line of code above you will see error messages on the BPS Security Status page
    # This is a standard generic htaccess file that does NOT provide any website security
    # The DEFAULT .HTACCESS file should be used for testing and troubleshooting purposes only
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Then I activated default for root folder and confirmed through FTP that the htaccess looked like it does in the BPS editor.

    Tried to load BPS options through dashboard, and it time outs. I also tried it after renaming the php.ini back to its original name, and it times out.

    It only seems to be able to open BPS options if I don’t have any handler information in the htaccess.

    Let me know what else you may think of.

    My frustration comes in not understanding well what information Bluehost creates within the php.ini file, and not understanding PHP in general. 🙁

    Okay, I also tried to disable all plugins except BPS and tried to open BPS options through WP dashboard and it still stalls/time outs. I can only open it if I remove the php handler at this point.

    Plugin Author AITpro


    Well unfortunately to me that means that your Host is doing something unusual with PHP5.4 (meaning not a standard default PHP5.4 Server installation or PHP5.4 Server configuration) or blocking something that is loading on BPS options page.

    Do your Server logs show what that might be?

    I will try to talk to the host again. I have checked the logs and there were things there. Is it safe to list those errors here? I thought of sharing them with you earlier but wanted to go through some initial steps.

    Do you think that the WP-Admin htaccess needs the php handler information?

    I may have just sounded really stupid regarding this.

    Thank you

    I asked that ^ because although I know the whole point of having a single.ini is that that htaccess file will work for the rest of the subfolders in case there are other htaccess files in those folders…

    So with there being one in WP admin, is there any conflict? Or like I said, does it need some custom code?

    thank you.

    Plugin Author AITpro


    Yes, it is safe if you change your actual real hosting account name using xxxx’s. WordPress has a Forum posting policy where it is ok to post snippets of code or log entries, but not ok to post excessive log entries or code (you would use pastebin for that) so just post no more than 10 log entries and wrap them in the code tags.

    No, the wp-admin .htaccess file does not need a php/php.ini handler and yes you are correct that using the single php.ini option means apply the php.ini settings sitewide based on the php/php.ini handler code in your root .htaccess file ONLY.

    Thanks for the answer regarding php hander in WP Admin’s htaccess. It was just a guess!

    Okay, as for the errors, unfortunately I have multiple errors for different folders, including public, admin, a plugin, and these are two errors for BPS folder, not sure if it relates to anything:

    [20-Aug-2013 01:04:18 UTC] WordPress database error Incorrect key file for table '/ramdisk/mysql/tmp/#sql_7a3b_1.MYI'; try to repair it for query SHOW COLUMNS FROM wp_terms made by require_once('wp-load.php'), require_once('/xxxxx/xxxx/wp-config.php'), require_once('wp-settings.php'), do_action('init'), call_user_func_array, AVH_EC_Core->handleInitializePlugin, AVH_DB->field_exists, AVH_DB->getFieldNames
    [20-Aug-2013 01:04:18 UTC] WordPress database error Duplicate column name 'avhec_term_order' for query ALTER TABLE wp_terms ADD <code>avhec_term_order</code> INT( 4 ) NULL DEFAULT '0' made by require_once('wp-load.php'), require_once('/xxxxxx/xxxxx/wp-config.php'), require_once('wp-settings.php'), do_action('init'), call_user_func_array, AVH_EC_Core->handleInitializePlugin

    If there is anything you can get out of that, let me know. I do notice a name of a plugin in these errors called AVH extended categories widget.

    I will uninstall it just because I don’t like seeing it in the error logs.

    Plugin Author AITpro


    these php errors from your php error log just show individual problems with the 1 plugin. check your Apache Server logs too.

Viewing 15 replies - 1 through 15 (of 56 total)
  • The topic ‘[Resolved] BPS Dashboard Options Page Won't Open’ is closed to new replies.