Support » Plugin: BuddyPress Docs » BP Docs doesn't support WordPress 3.7 now

  • Resolved yzqiang

    (@yzqiang)


    I updated WordPress 3.7 yesterday. After that, BP Docs doesn’t work properly. Doc page doesn’t show normal page presentation and looks weird. I checked many reasons but all doesn’t work.
    At last, I degraded WordPress back to 3.6.1. When I database is upgraded, I found the BP Docs works normally again. I think the database structure is the reason why doc page became weird.
    Please do something.

    http://wordpress.org/plugins/buddypress-docs/

Viewing 15 replies - 1 through 15 (of 34 total)
  • It looks like I might be having trouble with 3.7, too. I just installed BP Docs, so I am not 100% sure that the upgrade to 3.7 is the issue, but I know that it is trying to display all of the content from the document in the title field. Thanks for the help!

    Plugin Author Boone Gorges

    (@boonebgorges)

    Thanks for letting me know about this. I’ve confirmed the issue, and I’ll be releasing an update with a fix in the next day or so.

    And there are other errors:
    http://wordpress.org/support/topic/when-i-use-bracket-i-meet-some-errors
    http://wordpress.org/support/topic/bracket-doesnt-support-chinese
    Please review them and modify the error together. I expect them very much.
    Thanks very much.

    Plugin Author Boone Gorges

    (@boonebgorges)

    Thanks for the reports of the bracket issues. They are far less important than the WP 3.7 issue, so I will not be fixing them at the same time, but will look at them when I get a few spare moments.

    I also have problems! After updating the worpress 3.7 and BuddyPress update docs I have received in all 404 pages of documents. How can I fix this?

    Just another contribution on diagnostics : freshly installed wordpress 3.7 and buddypress, then buddypress docs (a few minutes ago)
    Got the same error 404 for viewing the documents ;
    But appending /edit or /history just works fine, so the permalink system doesn’t seem to be completely broken.

    Hope it helps
    Xavier

    Plugin Author Boone Gorges

    (@boonebgorges)

    MCLMarcos, xjimenez –

    Thanks for the reports. I’m afraid I’m unable to reproduce the reported issues using WordPress 3.7.1 + BuddyPress 1.8.1 + BP Docs 1.5.2. Can you please be specific about the versions of everything you are using? Are there any other relevant plugins you may be running? Any troubleshooting information you could provide would be helpful.

    Boone Gorges Hello!

    I understand what you said.

    I had everything working normally in BP Docs on WP 3.6 with various plugins installed.

    After upgrading to WP 3.71, access to documents lead to 404.
    It is as if the page does not exist.

    It can edit and view the historic but it is when you read the error happens 404

    Now updated to version 1.5.3 BP Docs and try to access the documents he is redirecting to / members /.

    It’s really weird.

    I understand the difficulty.

    I hope I helped you

    cheers

    I’m experiencing the exact same problem since i upgraded WP to 3.7, whenever any user tries to create a new file or edit an existing one, after pressing ‘save’ I get a 404 error.

    Other plugins on site:

    BackUpWordPress: 2.3.3
    Batch Create NEW: 1.3.2
    bbPress: 2.4.1
    bbpress Enable TinyMCE Visual Tab: 1.0.1
    BuddyPress: 1.8.1
    BuddyPress Community Stats: 0.5.1
    BuddyPress Docs: 1.5.3
    BuddyPress Group Email Subscription: 3.4
    Buddy Press Profile Visibility: 1.0.4
    Easy WP SMTP: 1.0.6
    Events Manager: 5.5.2
    GD bbPress Attachments: 2.0
    Jetoack: 2.5

    Plugin Author Boone Gorges

    (@boonebgorges)

    Those who are experiencing the problem:

    – Can you share the URL format of individual Docs on your site? Eg, http://example.com/docs/my-doc/ or whatever
    – What’s your setting at Dashboard > Settings > Permalinks?

    Boone,

    Thank you for working on the problem. Here is the info you requested:

    URL Format – http://example.com/docs/docname/
    Permalinks are set to Post name (also tried default).

    Let me know if you have any other questions.

    I forgot to say that when I click on the title (or the read link) of a document, it takes me to http://example.com/groups/. When I click on “edit” it takes me to http://example.com/groups/edit. When I click on “history” it takes me to http://example.com/groups/history.

    Also, in case it helps, I am using 3 of the same plugins as one of the other posters (in addition to Docs):

    bbPress: 2.4.1
    bbpress Enable TinyMCE Visual Tab: 1.0.1
    BuddyPress: 1.8.1

    Hopefully this helps.

    Thanks Boone. My permalink setup is also set for post name. So in my case:

    https://example.com/sample-post/

    So its also

    https://example.com/docs/docname

    Thanks

    Boone

    Thanks for the effort in adjusting

    Now updated the plugin and the error continues

    In my site the URL is http:/exemplo.com.br/members in all Docs

    On the other hand, if http:/exemplo.com.br/docs/DocName digit, as before, the error occurs 404

    Thanks

    Plugin Author Boone Gorges

    (@boonebgorges)

    Hi everyone – It looks like the problem is related to the use of “post name” as the permalink settings. It turns out that there’s a somewhat obscure bug in WordPress 3.7 that this issue has uncovered: http://core.trac.wordpress.org/ticket/25798

    Docs 1.5.4 should fix the issue. Please let me know when you’ve had a chance to update.

Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘BP Docs doesn't support WordPress 3.7 now’ is closed to new replies.