Support » Plugin: Boxzilla » Boxzilla using Custom post type with second rule

  • Resolved Lance

    (@lancernz)


    The box is required to load for a custom post type – and it does, it’s perfect.
    What we are trying to achieve is load a box depending on a tag, or category.
    It will only load if ‘Post type’ is set to the custom type. It won’t load based on a second condition (tag or category).
    If I set only a category or tag (delete ‘Post type’) it won’t display at all.
    Any ideas please?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Lap

    (@lapzor)

    Can you show me a screenshot of your settings with the Category added and also show me a screenshot or link where I can confirm the category slug or id?

    9/10 with this sort of problem it was an incorrectly typed slug or category ID.

    Also note you can switch between matching “any” or “all” conditions depending on your needs. It it’s set to match all conditions the posts needs to be the poste type AND be assigned to the category.

    Hope that helps. If you have any questions, please let me know!

    Thread Starter Lance

    (@lancernz)

    Sure thing.
    It auto-populates the tag/category field when creating the rule, so eliminates typo errors. When I set the Request matches ‘all’ is when things stop.

    It seems to not display the box in Custom Post Type by using just the category or tag and only when ‘Post type’ is sole set (no other conditions).

    Screen shots as links:
    http://gli.tkr.nz/screen/Post-tag.png
    http://gli.tkr.nz/screen/Box-working.png
    http://gli.tkr.nz/screen/Box-works-2.png
    http://gli.tkr.nz/screen/Box-not-working.png

    Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hey Lance,

    Is this custom taxonomy or the tags provided under “Posts > Tags” menu?

    Thread Starter Lance

    (@lancernz)

    Hi Harish,

    Under “Posts > Tags” menu. Screenshot here: https://prnt.sc/r1k695

    Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hey Lance,

    Can you please try using “perry-james” instead or maybe the ID of the tag? You can get the ID by click on “Perry James” and then the ID would be in the URL.

    Thread Starter Lance

    (@lancernz)

    Sure thing,

    Tried that, and the tag id (150). No result.
    Changed the order of the conditions (put post type second), didn’t make any difference.

    Another test I’ve just tried was setting the category.

    First test: https://prnt.sc/r1nge6 = didn’t work
    Second test: https://prnt.sc/r1ni2w = didn’t work

    So if I try using just the tag or category it doesn’t work. The only way it displays is using the condition ‘everywhere’ or ‘post type’.

    Hope that helps!

    Thread Starter Lance

    (@lancernz)

    Let me know if you’d like login credentials for this site (it’s a dev site currently).

    Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hey Lance,

    Can you please also share a link where the pop-up works?

    Also, can you please make a another pop-up to show on your posts with a specific category (not custom post type).

    You can share the details using the email at https://boxzillaplugin.com/contact/.

    Thread Starter Lance

    (@lancernz)

    Sure thing – have emailed you. Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Boxzilla using Custom post type with second rule’ is closed to new replies.