Support » Theme: Customizr » Bouncing header/navbar

  • Hi everyone,

    I use a slider on my site. Right now it’s the same on everypage.

    Problem I have is when I navigate from one page to another, in FF, both the navbar and slider keep bouncing around when the page loads. In Chrome, only the slider bounces (just a bit though).

    Anyone got a suggestion what to do to stop that?

    I’m guessing it has to do with sizes but, FYI,
    – Logo and slider images respect the Customizr themes standard sizes (logo is : 250×45, slider image is 1170×500)
    – Header is set to sticky on scroll
    – Sticky header: shrink title/logo is disabled
    – Sticky header: display the title/logo is selected
    – Sticky header: display the menu is selected

    Thanks in advance to all who reply.

    Marc

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Huh… When I disable the sticky header. All is fine!?! Not what I wanted for my site but guess it will have to do…

    Hi Mdugre,

    I can’t reproduce the problem on my end or on your page. I would recommend trying the following troubleshooting steps.

    1. Use the latest software versions : make sure WordPress, your theme and plugins are all up to date.
    2. Cache plugin : if you use a server cache or cache plugin, please clear it’s cache content and disable caching via it’s settings.
    3. Browser :
    4. Check for plugin conflict : deactivate all of your plugins. If it fixes the issue, re-activate your plugins one by one, until you identify the plugin in conflict.
    5. User of a child theme : activate the parent theme if you use a child theme
    6. Javascript : make sure you did not insert custom javascript code ( like analytics, subscription popup… ), for example in a widget, that could break your site.

    Thank-you for the suggestions Emranemranx.

    I do use the latest software versions on everything and Customizr’s child theme.

    As far as the plugins go, I deactivated all of them and tested the site without. Problem was still there so, reactivated one by ones and tested again each time. They are not the problem.

    Clearing my browser’s cache/history is SOP with me. That’s not the problem. RE: Javascript, I took out everything. Didn’t do anything and I didn’t see any code that could break my site.

    RE: different browsers, I have to make sure my site works with all of the most popular browsers so…

    Like I said, in my previous post on this, only solution I found so far is to disable the sticky header. Not the perfect solution but, at the end of the day, I can live with it.

    Cheers,

    Marc
    System’s information
    ### Begin System Infos (Generated 2019-04-30 13:30:46) ###
    ———— SITE INFO
    Site URL: http://www.datatelcom.com
    Home URL: http://www.datatelcom.com
    Multisite: No

    ———— USER BROWSER
    Platform: Windows
    Browser Name: Firefox
    Browser Version: 66.0

    ———— WORDPRESS CONFIG
    WP Version: 5.1.1
    Language: en_CA
    Permalink Structure: /%postname%/
    Active Theme: Customizr Child 1.0.0
    Parent Theme: Customizr 4.1.38
    Show On Front: page
    Page On Front: Home (#2117)
    Page For Posts: BLOG (#3287)
    ABSPATH: /nfsvol-b/43/51943/datatelcom.com/nic_wordpress/
    WP_DEBUG: Disabled
    WP Memory Limit: 40MB

    ———— NIMBLE CONFIGURATION
    Version: 1.7.1
    Upgraded From: 1.7.0
    Started With: 1.1.9

    ———— WP ACTIVE PLUGINS
    Broken Link Checker: 1.11.8
    Google Fonts for WordPress: 1.6.3
    Gutenberg: 5.5.0
    Nimble Page Builder: 1.7.1
    Polylang: 2.5.3
    TinyMCE Advanced: 5.1.0
    VFB Pro: 3.3.9
    WP Fastest Cache: 0.8.9.2
    Yoast SEO Premium: 11.0

    ———— WP INACTIVE PLUGINS
    Disable Gutenberg: 1.8.1
    Regenerate Thumbnails: 3.1.0
    Smush: 3.2.0.1
    Title Remover: 1.2
    VFB Pro – Form Designer: 2.0.5
    Wordfence Security: 7.2.5

    ———— WEBSERVER CONFIG
    PHP Version: 7.2.8
    MySQL Version: 5.1.66
    Webserver Info: Apache/2.4.33 (Amazon)
    Writing Permissions: OK

    ———— PHP CONFIG
    Memory Limit: 256M
    Upload Max Size: 2M
    Post Max Size: 8M
    Upload Max Filesize: 2M
    Time Limit: 30
    Max Input Vars: 1000
    Display Errors: N/A
    PHP Arg Separator: &
    PHP Allow URL File Open: 1

    ### End System Infos ###

    Hi Marc,

    Thanks for confirming! Please do let me know if there’s anything else I can help with.

    I have got the same issue on https://pferdetermine.de
    I don’t think it is a good solution to deactivate the sticky header. The sticky header has been one of the advantages of customizr. So a better solution would be appreciated.

    I agree pferdetermine but since for the life of me I can’t find one and just like you I like Customizr, I didn’t see any better way.

    I found other themes that work well with the sticky header but, even though my site is small, the amount of work required to implement these is way to much. Not to mention the incompatibilities with the plugins I use… Don’t need the headaches if you know what I mean 😉 😉

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Bouncing header/navbar’ is closed to new replies.