Support » Theme: WP-Forge » Both Off-canvas and Top-bar menu showing after update to 5.5.2.2 ?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Theme Author Thomas

    (@tsquez)

    Look at the documentation: http://themeawesome.com/docs/wp-forge

    The link is also under appearance>about WP-Forge

    Look under off-canvas section

    My apologies, as I should have been a little more clear.

    I only want the top bar to display. I do not want to use off-canvas. For Navigation Section > Menu Selection, I picked Top Bar. However, both the top bar and off canvas menus are showing. Am I missing something, or is this normal?

    Theme Author Thomas

    (@tsquez)

    Are you using s child theme? With a child header.php file? If so you need to replace the child header file because the coding in the header is different.

    Theme Author Thomas

    (@tsquez)

    Just wondering if that worked for you? The header.php file has some new lines of code to accommodate the use of the off-canvas menu as a regular menu.

    If you are using a child theme and you have a copy of the .header.php in your child theme, you need to add any and all edits to this new copy of the header.php file then add it to your child theme.

    If I have noticed a few things will and can happen. The menu may disappear and you may see two menus.

    Thanks for bringing this to my attention and to everyone else’s.

    Since we’re on the subject of the header.php file, should the * @since WP-Forge 5.5.1.7 line be updated to 5.5.2.2?

    Not really sure how that header comment stuff is supposed to work, and diffing against the entire theme code is time consuming 🙂 thanks.

    Theme Author Thomas

    (@tsquez)

    Ah there you are, I was wondering when you would chime in 😉 – Anywho the 5.5.1.7 is when the header file is supposed to have appeared in the theme. Since 5.5.1.7 is the first “official” release of WP-Forge and this is when the header file made its debut its safe to leave the version number as is.

    Now if we really want to get technical, as some do, then the argument could be made that seeing s how some of the code was changed in the file, then this should be changed to the most current version. 5.5.2.2

    However I disagree. Now that I think about it, and now that you bring it up, I should have maybe put a comment near the code that was changed. My apologies, I will make this happens in the next update.

    I do think that whenever an update is released and a child theme is being used, that any and all files should be checked to see if there are any changes to the original parent files. At least this is what I would do

    🙂 Just keepin it real.

    I do think that whenever an update is released and a child theme is being used, that any and all files should be checked to see if there are any changes to the original parent files. At least this is what I would do

    Exactly my point regarding diffing against your source… or any source.

    I am using a child theme, and once I copied the new header.php into my child theme folder and made the necessary updates, it seems to be working fine now.

    I must have not been in my right mind. 😛 Thank you for your help!

    Theme Author Thomas

    (@tsquez)

    Lol Joseph no worries amigo, just glad you got it all worked out and everything is working as it should be.

    Sadly This is not working with my site
    I am using WP 4.3 RC, PHP 5.4
    In preview i can see the top menu but after save disappear

    Theme Author Thomas

    (@tsquez)

    Hi Dryer,

    Let’s see if we can’t get this taken care of. I see that you are using a child theme. OK, so first off, I know this is going to sound off the wall but have you assigned a menu to that nav area?

    Next what you need to do is go into appearance>navigation section>Top-Bar Settings and switch the settings they are currently set at to something else, like contain to grid sticky. Then click save and publish. As soon as the customizer has finished saving the settings go back and change the top-bar settings to what they were before then click save an publish again. Now go to your site, and hit refresh.

    I believe this may be happening to existing users because the new areas and the new settings in the customizer are not in the db yet and therefore need to be added. This should add them and everything should work the way its supposed to.

    Hope this helps and please let me know how it goes.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Both Off-canvas and Top-bar menu showing after update to 5.5.2.2 ?’ is closed to new replies.