Support » Plugin: Sponsors » Shortcode Borks when used in Gutenberg

  • After I installed Gutenberg I could add a shortcode block with the Sponsors shortcode. It previews, displays and saves fine. I was so happy, that it would work out of the box.

    However when I accessed the post again with Gutenberg, I received a white screen with no error message in the browser console, but my debug log registers this error message:

    PHP Notice: Undefined index:
    “wp_sponsor_link_behaviour in /app/public/wp-content/plugins/wp-sponsors/includes/class-wp-sponsors.php on line 334”

    I used a clean WP instance to test with only the two plugins installed: Sponsors and Gutenberg.

    Here is a video: http://recordit.co/ZNYzvAvcPK

    Let me know what else you need to replicate it and to troubleshoot this.
    Update:
    I was able to replicate above test on two different environments, both on nginx + w/ Gutenberg 3.2 and WP 4.9.7 – PHP version (1) 7.1.7 and (2) HHVM/3.19/2-dev
    ==
    I did not encounter these problems on php 5.8 / WP 4.9.6 and Gutenberg 3.0

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author janhenckens

    (@janhenckens)

    Hey Birgit!
    I haven’t kept up with Gutenberg development in the last months, will take a look this week to see if I can make the plugin compatible.

    Plugin Author janhenckens

    (@janhenckens)

    Hey Birgit, where did you see that error message?

    Also, there is no version of PHP called 5.8, not sure what you tested on.

    This is definitely a code issue so you don’t have to go and test with nginx/apache/hhvm and all that.

    The error message shows up on top of the “Add new post” screen only very briefly, that’s why I had the error message logged into the Debug log.
    You need Gutenberg 3.2 plugin installed. I don’t think the message happens with earlier version.
    The white screen happens after you add a short code block, publish it. It might give you already an error message which isn’t very helpful and nothing in the browser console either.
    When you go back the “post” list, and click on edit post, it gives you the white screen.

    You should see it all in above video, I thought.

    Plugin Author janhenckens

    (@janhenckens)

    Yes, the video makes it very clear, thanks for that.

    I just can’t seem to get error on screen on my end. I’ve fixed the issue you mentioned first but there must be another one because the screen stays blank.

    Any pointers on how to enable the debug log thing? I’ve been out of WordPress land for a while so I might have missed some things…

    Thanks!

    You are welcome.
    use a setting in your wp-config.php

    define( 'WP_DEBUG_LOG', true );
    You’ll find the debug.log file in wp-content

    Let me know if you need to test a version again:-)

    This seems to be fix with the newest version. Thank you, Jan!

    Plugin Author janhenckens

    (@janhenckens)

    Yes!
    I totally forgot to update this ticket though 🙂

    Thanks for using my plugin!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.