Support » How-To and Troubleshooting » Borders on Images

Borders on Images

Viewing 15 replies - 1 through 15 (of 16 total)
  • media=”all”
    img[class*=”align”], img[class*=”wp-image-“], #content .gallery .gallery-icon img {
    border: 1px solid #ddd;
    padding: 6px;

    Change to:

    border: none;

    Hi 2ninerniner2,

    thanks for your prompt reply, sorry for the delay. i have tried to decipher what you have said but I’m not sure what it is you’re asking me to do and where the code is that im looking for and for which problem you are trying to help me with.

    Excuse my lack of knowledge, could you be more descriptive please, for a ‘beginner’..


    I see you are using a child theme … good job! 🙂

    This is for the elimination of the border.

    Copy and paste this CSS into:

    http://culturedcarpbaits.co.uk/wp-content/themes/twentyeleven-child/style.css after the last entry (on a new line):

    img[class*=”align”], img[class*=”wp-image-“], #content .gallery .gallery-icon img {
    border: none;
    padding: 6px;

    Hi again,

    thanks, i copied and pasted this:

    img[class*=”align”], img[class*=”wp-image-“], #content .gallery .gallery-icon img {
    border: none;
    padding: 6px;

    to the bottom of the CSS but nothing happened?

    sorry to be a pain

    im accessing the css through the ‘appearance – editor menu on the dashboard if thats correct?

    Are you able to access the CSS via ftp?

    You can probably just add this to your CSS file and it will override the settings as they are now:

    img { border: none !important; }
    img:hover { border: none !important; }

    And to move the image/content closer to the header you will need to remove the top padding on the .entry-content div like so:

    .entry-content {
       padding-top: 0;

    Hi Evan,

    thanks, I have added the code you both gave me to the editor and to the child theme css site on the ftp server but still no joy unfortunately.

    this is already in my css if thats any use (but i dont think it is)

    /* Site Generator Line */
    #site-generator {
    background: #000;
    border-top: 1px solid #ddd;
    color: #000;
    font-size: 1px;
    line-height: 0.1em;
    padding: 1em 0.1em;
    text-align: center;


    When you edit the CSS file through FTP are you editing the file within
    wp-admin/themes/twentyeleven/styles.css ?

    You must have conflicting CSS styles, adding them to your CSS editor on the dashboard should over write any previous styles set.

    no, i dont have that option. its in the wp-content/themes/twenty-eleven-child.

    in the wp-admin file i have /css/images etc

    Im sorry thats what I meant, wp-content (not admin)

    Do you see this in your CSS file

    img[class*="align"], img[class*="wp-image-"], #content .gallery .gallery-icon img {
      border: 1px solid #ddd;
      padding: 6px;

    When I view your site in the inspector that is the style I see that is causing images to have the border.

    ive got to leave work but i will look later to see if you can help! thanks again, both of you..

    hi, no i don’t see that in my css file.

    any ideas?

    Please help.
    I tried to upload image from my computer to the post without success. The problem is that when I click upload in insert media, it says no item found. Attempt to upload image or picture has not been successful. help.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Borders on Images’ is closed to new replies.