WordPress.org

Forums

bookmarklet... (13 posts)

  1. amoen
    Member
    Posted 11 years ago #

    Hi!
    ive installed the bookmarklet in my registry but somehow it doesnt work. i get this javascript-error message and dont know what it means...
    does anybody know how to remove it from my registry?
    thanx,
    jeroen

  2. Mark (podz)
    Support Maven
    Posted 11 years ago #

    This should work...
    Run regedit, Find 'wordpress' and delete the 3 keys you find.
    Careful though :), it *is* the registry !

  3. Mark (podz)
    Support Maven
    Posted 11 years ago #

    Scrub the above !
    The adding to the registry does not work for me either, and I get the same error.
    Start > Run > regedit
    search for 'wp-admin' and delete the value.
    The key remains, but if you close and reopen your browser, the bookmarklet option will have disappeared.
    I had a similar problem when I tried Nucleus, and I seem to remember there was a workround for it, but as the rest of that program was unfriendly, I didn't pursue it.

  4. amoen
    Member
    Posted 11 years ago #

    thanx podz!
    i'll remove it for now...
    but does anybody know how i can get it working?

  5. Mark (podz)
    Support Maven
    Posted 11 years ago #

    I wish I did... I've just spent some time hunting around without success.
    I get:
    "error: 'external.menuArguments.document' is null or not an object"
    URL:
    javascript:doc=external.menuArguments.document;Q=doc.selection.createRange().text;void(btw=window.open('http://www.tamba2.org.uk/T2/wp-admin/bookmarklet.php?
    If I try the 'Press-It' favourites, I get a blank screen, with 'Done' in the bottom left, and this address just sits in the address bar:
    javascript:Q='';if(top.frames.length==0)Q=document.selection.createRange().text;void(btw=window.open('http://www.tamba2.org.uk/T2/wp-admin/bookmarklet.php?text='+escape(Q)+'&popupurl='+escape(location.href)+'&popuptitle='+escape(document.title),'bookmarklet','scrollbars=yes,width=600,height=420,left=100,top=150,status=yes'));btw.focus();
    There is some sort of solution to this for Nucleus users, but the coding is way over my head. Might be useful to someone who does know their stuff ?
    http://forum.nucleuscms.org/viewtopic.php?t=1533&highlight=bookmarklet

  6. amoen
    Member
    Posted 11 years ago #

    yep same codes over here...
    and they are more than way over my head ;)
    so is there anybody out there who does know how to fix this?

  7. Laughinglizard
    Member
    Posted 11 years ago #

    @amoen and others: Here is a small temporary fix as emulated from the Nucleus site (one of their answers is flawed and their own code has bugs, oh well)
    Create a new file on the root of your blog called rightclick.php and put the following in there (replace open('http://... with your own servername):
    <script type="text/javascript" defer="defer">
    doc=external.menuArguments.document;
    lt=escape(doc.selection.createRange().text);
    loglink=escape(external.menuArguments.location.href);
    loglinktitle=escape(document.title);
    open('http://yourserver.com/yourweblogdirectory/wp-admin/bookmarklet.php?text='+lt+'&trackback=1&pingback=1&popupurl='+loglink+'&popuptitle='+loglinktitle,'bookmarklet','scrollbars=no,width=480,height=590,left=100,top=150,status=yes')
    </script>
    Now create another file on your desktop called wordpress.reg and put the following in there (again replace the varibles please):
    REGEDIT4
    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\MenuExt\Post To &WP : Mindful Musings]
    @="http://yourserver.com/yourwordpressdirectory/rightclick.php"
    "contexts"=hex:31"
    Now double click on the wordpress.reg file to add the information to the registry and the right click in IE should work at that point.
    Peace

  8. Anonymous
    Unregistered
    Posted 11 years ago #

    I had the same problem, tried this fix, and it worked great with one correction....
    change in rightclick.php
    loglinktitle=escape(document.title);
    to
    loglinktitle=escape(external.menuArguments.document.title);
    Thanks again....Ravi

  9. Anonymous
    Unregistered
    Posted 11 years ago #

    Well, thanks Ravi...I finally got this to work...YEAH! I do have one last question though. I now have two entries in the right click menu, and would like to 'disappear' one of them. I went into regedit and searched for "wordpress", deleted the three keys...but like a bad penny, the link will not go away?
    Thanks in advance (and yes, I closed and reopened the browser, and also deleted the cache files ??)
    Mark

  10. PetLvr
    Member
    Posted 9 years ago #

    Is this still and active forum? That revised "mindful musing" right-click bookmarklet works great. I have no idea and have unsuccessfully tried to delete entries from my registy before installing this new wordpress.reg script to no avail. In my I.E. if I right click, I still see the old one "Post to WP (my blogsite)" ... Can someone explain how to remove this from my IE browser? I don't care if it stays in my registry (ok I do) but it's very annoying having two of them ..
    Thanks in advance
    HART

  11. PetLvr
    Member
    Posted 9 years ago #

    FOLLOW UP! Good News.. I found this link that had quite useful instructions how to remove items from your Right Click on the menu.
    http://malektips.com/internet_explorer_6_0012.html

  12. oasis-k
    Member
    Posted 9 years ago #


  13. oasis-k
    Member
    Posted 9 years ago #

    sorry... posted in wrong thread

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.