Support » Plugin: Booking Activities » Booking Button stopped working

  • Resolved wpletter

    (@wpletter)


    It just started yesterday.
    I have one-click checkin set up, so students go on the calendar (change to monthly view) then click on the events they want to check in for.

    Up to yesterday it was working.

    1) Today, every event shows still max capacity of 14. When I check as admin and go on the Calendar editor, I see how many spots really are left (since several users already checked in for several of the upcoming events). But the calendar acts, as if there were no bookings.

    2) Worse: When I click on a event to add my checkin, it’s non responsive. It will not accept my click.

    I copied the calendar to a test page you can see without having a user:

    https://improlab.ch/test-page-booking-activities/

    same bug there.

    Help would be very much appreciated.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author yoancutillas

    (@yoancutillas)

    Hello,

    1. What do you mean? can you describe? The availabilities are displayed as “0/14” in the Calendar Editor?

    2. I can’t see any event on the test page, can you make sure they are visible for non logged in users? (Or give me test credentials)

    Regards,

    Hi
    The description should speak for itself – but you have no access, I just tested it sorry!
    But now I’m confused – You can see the calendar (tested it, without being logged in) but you see no events.

    Is that a booking-activity security feature? Where is the security settings that let me say “everyone”?

    Plugin Author yoancutillas

    (@yoancutillas)

    You may have restricted your activities to certain roles,
    – Go to Booking Activities > Calendar Editor
    – Go to the activity setting > Permission tab
    – Unselect all the roles (with CTRL+Click) in the “Who can book this activity?” option
    – Validate the dialog

    Ok, I got you.
    Log in here: https://improlab.ch/login/

    Where can I send you your login credentials?

    after you login, try the page again:

    https://improlab.ch/test-page-booking-activities/

    Plugin Author yoancutillas

    (@yoancutillas)

    You can send the credentials at contact@booking-activities.fr

    Plugin Author yoancutillas

    (@yoancutillas)

    This problem is probably due to a conflict with another plugin.

    Can you try to add this code in wp-content\plugins\booking-activities\booking-activities.php line 130
    if( wp_script_is( 'moment', 'enqueued' ) ) { wp_dequeue_script( 'moment' ); }

    If it still doesn’t work, can you follow the instructions below “Booking Activities doesn’t work as it should” on that page in order to identify the plugin in conflict?

    EDIT:
    Sorry, no need to test, the problem come from the google-calendar-events plugin.
    It includes its own version of moment.js and enter in conflict with Booking Activities’.

    • This reply was modified 8 months, 4 weeks ago by yoancutillas. Reason: Plugin in conflict identified

    Well, you got me on “plugin conflict”.
    I only did ONE thing to the site yesterday, and that was to install the Simple Calendar.

    I just deactivated it, and lookie here: Your plugin works again!!!

    Do you think adding your code will let me run both plugins together?

    Plugin Author yoancutillas

    (@yoancutillas)

    No, because it includes its own version of moment.js, not WordPress’ core one as I suspected.

    You can try to add this code in your child theme functions.php (or with Code Snippets):

    function my_theme_dequeue_simcal_moment_js() {
    	if( wp_script_is( 'moment', 'enqueued' ) || wp_script_is( 'bookacti-js-moment', 'enqueued' ) ) {
    		if( wp_script_is( 'simcal-fullcal-moment', 'enqueued' ) ) { wp_dequeue_script( 'simcal-fullcal-moment' ); }
    		if( wp_script_is( 'simcal-moment-timezone', 'enqueued' ) ) { wp_dequeue_script( 'simcal-moment-timezone' ); }
    	}
    }
    add_action( 'admin_enqueue_scripts', 'my_theme_dequeue_simcal_moment_js', 100 );
    add_action( 'wp_enqueue_scripts', 'my_theme_dequeue_simcal_moment_js', 100 );

    If it doesn’t work, you will need to contact their support to ask how to properly disable their moment.js.

    EDIT:
    Booking Activities and Simple Calendar don’t use the same version of moment.js, doing so may cause Simple Calendar to malfunction.

    • This reply was modified 8 months, 4 weeks ago by yoancutillas. Reason: warning about compatibility

    Yeah… I’m a noob 🙂
    And I was not happy with the calendar anyway! So I’ll just deinstall it.

    Again: Top Support man!

    Plugin Author yoancutillas

    (@yoancutillas)

    No problem, thank you! 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Booking Button stopped working’ is closed to new replies.