Support » Plugin: Docs to WordPress » Bold/italic, links, categories, authors no longer transfer

  • Resolved piantadosi

    (@piantadosi)


    Is any of this coming?

    A month or so after they said they’d shut off the old Docs API, Google finally did, sometime this week. The reason I know is because I had reverted to the old Docs to WP version since it was still apparently working and has served us without fail for three or four years —but mostly because the previous version at least transferred text attributes, links, categories (if they matched Drive folder names) and authors (if the lefthand side of their Gmail address matched their WP username). But none of this is working in version 1.1.

    The new version transfers docs fine but none of those attributes, which in our case more than doubles the amount of time it takes to get stuff online from our Docs editing system.

    I’m not great with php but if anyone has any hints (or is experiencing the same unexpected changes in 1.1), I would love to hear from you.

    https://wordpress.org/plugins/docs-to-wordpress/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Also, comments in the Doc and a link to open it for editing from WP also no longer transfer.

    Hi piantadosi

    I am experiencing the same since updating to 1.1 as i too was caught out by google pulling the plug!

    Loosing the bold and italic styling is a big deal for me.

    Hopefully someone can find the solution soon.

    Matt

    Whilst running the beta version for the last year i have been running a modified version of the ‘extend-clean.php’ add-on to strip the google tracking from hyperlinks, add support for tables and add some styling to certain elements. So i am reasonably familiar with how it works.

    My guess would be that the problem lies at line 16. Where it is generating an array of bold spans. I imagine that the regex needs tweaking but I don’t know enough regex to work out what.

    When you import a post with the extend-clean addon disabled then bold items come in with a span of <span class="c8">Bold Text Here</span> (note that that the digit isn’t always an 8). It looks to me as though this part isn’t needed: {(.*?)font-weight:bold(.*?)} but again i have only dabbled a little with regex.

    Maybe that helps someone. Or maybe not! 🙂

    Matt

    Just adding a note to point to my latest post about a fix for this. See my post here

    Plugin Author William P. Davis

    (@wpdavis)

    Matt,
    Thanks for the fix on this. Looking forward to merging it into the core plugin.

    Will

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Bold/italic, links, categories, authors no longer transfer’ is closed to new replies.