WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Bolding Text in a table

[Resolved] Bolding Text in a table

  • Hello,

    I’m creating tables to use on my website by exporting Excel spreadsheets as HTML by using an excel add-on called ASAP utilities. It exports bold text with < b> tags, which are then imported into my tables. When I preview the table after importing, the text shows as bold, but when I actually place a table on a page on my site, nothing is bolded. I noticed that when I use the advanced editor to bold an individual cell, it uses a “strong” tag, not a “b” tag. Is there any way to make these < b > tags from my excel exports keep their bold appearance in the tables?

    http://wordpress.org/extend/plugins/tablepress/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author TobiasBg

    @tobiasbg

    Hi,

    thanks for your post.

    Whether a <b> or <strong> tag is used doesn’t actually matter, as both are valid HTML tags.
    Now, there’s probably some issue in the CSS code of your site.

    Can you maybe post a link to a page with a table that shows this behavior? I will then gladly take a look!

    Thanks!
    Tobias

    Hi,

    Here is a link to one of the pages:

    Site

    A number of the headings are supposed to be bolded, but do not display that way on the page.

    Thanks

    Plugin Author TobiasBg

    @tobiasbg

    Hi,

    thanks for the link!

    Indeed, for some reason your <b>s are reverted to normal font-weight by your theme. To fix that, please add

    .tablepress b {
        font-weight: bold;
    }

    to the “Custom CSS” on the “Plugin Options” screen of TablePress.

    Regards,
    Tobias

    Great,

    thanks for your help!

    Plugin Author TobiasBg

    @tobiasbg

    Hi,

    sure, no problem! You are very welcome!

    Best wishes,
    Tobias

    P.S.: In case you haven’t, don’t forget to rate the plugin here in the plugin directory. Thanks!

    Hi Tobias – I am having the exact opposite problem – text I do NOT mark as bold is showing up bold. http://whitmanwellnesscenter.com/workshops/
    It appears as if all the first paragraphs in the middle column are showing up in bold when they are not marked that way in the table. Any suggestions? Thank you!

    Plugin Author TobiasBg

    @tobiasbg

    Hi,

    thanks for your post, and sorry for the trouble.

    The reason for this is that the [table /] Shortcode on the page is wrapped in HTML <strong> tags. Please go to the “Edit” screen of the page, switch to the “Text” editor (away from the “Visual” editor) in the upper right corner of the editor. After that, you will see the page content as HTML code. There, you’ll see something like this:

    <strong>
    
    [table id=1 /]
    
    </strong>

    Please remove the <strong> tags around the Shortcode, so that it stands on its own line with an empty line before and after it.

    Regards,
    Tobias

    Brilliant! I appreciate your responsiveness Tobias! Many thanks!
    Carol

    Plugin Author TobiasBg

    @tobiasbg

    Hi Carol,

    no problem, you are very welcome! 🙂

    Best wishes,
    Tobias

    P.S.: In case you haven’t, please rate TablePress here in the plugin directory. Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Bolding Text in a table’ is closed to new replies.