WordPress.org

Support

Support » How-To and Troubleshooting » Body element already open?

Body element already open?

  • I come to you hat-in-hand…

    When validating hypervocal.com ( link to validation )

    W3C validator comes back with:

    “An body start tag seen but an element of the same type was already open.”

    I can not see where it is already open.

    I would appreciate any help in tracking down the issue here.

    Thanks in advance.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi Antigrav,

    The problem is probably due to the fact that you have a <div> tag inside your document’s <head>:

    <div id="top-header">

    Move that tag and all it’s contents to the <body> of your document and the error should go away.

    Cheers!

    Thank you Marventus… I actually made that change in our dev environment and I’m still getting the same validation error.

    Any other ideas?

    Is there a chance you could upload those changes to production or send me a link to your dev environment so I can take a closer look? If you would rather not make the dev address public, you can send it to me to `
    [mynickname].wp{at}Google_Mail{dot}com
    `
    Cheers!

    Info Sent.

    Thanks so much Marventus, you are a gentleman and a scholar.

    Just in case someone else finds this thread and is experiencing the same error, the original validation error related to the <body> was caused by improperly placed HTML outside of the body tag. The culprit seems to be a plugin, but I could not verify it for sure.

    Hi there.
    If you were able to figure out the original validation error, could you please mark this thread as resolved?
    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Body element already open?’ is closed to new replies.
Skip to toolbar