Support » Plugin: Wordfence Security - Firewall & Malware Scan » Bluehost deactivated site because of Wordfence

  • Resolved kevmeister

    (@kevmeister)


    Today Bluehost deactivated my site because it was “causing performance problems.” When I called to get the site restored, they refused unless I turned off Wordfence, which was creating significant problems, in violation of my Terms of Service.

    Has anyone else run into this problem? I don’t like leaving my site unprotected, but I can’t reactivate Wordfence until the issue is resolved. Everything on my WordPress site up to date.

    Is there any fix in the works?

    • This topic was modified 2 years, 6 months ago by  .
Viewing 4 replies - 1 through 4 (of 4 total)
  • Yes, it seems there is something odd going on with the latest version.
    Checked the log this morning to find this entry:

    [Sep 30 08:30:58:1475220658.457443:2:error] Scan terminated with error: Wordfence file scanner detected a possible infinite loop. Exiting on file: wp-content/uploads/2016/08/product.jpg
    [Sep 30 08:30:54:1475220654.584316:2:info] Analyzed 5337800 files containing 79.08 GB of data so far

    1, The drive only has 30gb max. 2, Site size is around 700mb max including installation.
    Disk I/O, CPU charts are through the roof when running scan, bandwidth spikes but settles in less than a minute.

    Hi kevmeister and DeaJae,
    This could be related to one of the cases that our team is looking into it. In the meantime, I would suggest the following:
    – Uncheck “Scan images, binary, and other files as if they were executable” from (Wordfence > Options => Scans to include).
    – Exclude any large files in size or folders with large number of files that you are sure they aren’t malicious (like backup files or folders that include cached files in case you are using a caching plugin). For reference, check “Exclude files from scan that match these wildcard patterns“.

    @kevmeister Along with what I mentioned above, did you try the new “low resource scanning“? it’s right there under (Wordfence > Options => Scans to include). I would recommend it in this situation you have.

    Let me know how it goes,
    Thanks.

    Okay, I turned on the low resource scanning option. Do I need to change the amount of memory that Wordfence requests while scanning?

    Thanks for the tip. I’ll be back if I get another deactivation.

    • This reply was modified 2 years, 6 months ago by  .

    I’m not sure about the current value you have for “How much memory should Wordfence request when scanning“, but a value of 256 there should be fine, let me know if you encountered with any memory related issue while scanning.

    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Bluehost deactivated site because of Wordfence’ is closed to new replies.