WordPress.org

Support

Support » How-To and Troubleshooting » BlueHost 404 Errors after Changing Slugs on WordPress Pages

BlueHost 404 Errors after Changing Slugs on WordPress Pages

  • I changed the Slugs on my WordPress pages and now BlueHost displays 404 errors when attempting to access the pages. I’d greatly appreciate it if someone could tell me how to fix this problem.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Moderator sterndata (Steve Stern)

    @sterndata

    How did you change the slugs?

    I changed them with the Quick Edit feature for Pages in WordPress. There should be a warning if editing the Slugs for Pages in WordPress is going to cause these kinds of problems.

    Moderator sterndata (Steve Stern)

    @sterndata

    Try resetting your permalinks from settings->permalinks.

    I tried that several times even though I thought perhaps this only applied to Categories and Tags versus Pages.

    Moderator sterndata (Steve Stern)

    @sterndata

    Please provide a link to your site! Thanks.

    Also, what’s a sample of an old link and new one?

    Here’s an example:
    Old: http://www.primefourierseries.com/?page_id=100
    New: http://www.primefourierseries.com/definitions/

    I changed my Permalink Settings from “Post name” back to “Plain” and my pages can now be accessed again, but I’d like to display more meaningful URLs.

    Moderator sterndata (Steve Stern)

    @sterndata

    You changed the slugs to do that? That’s what permalinks are for.

    Anyhow, the 404 page you get is a BH page, not a WP page. That indicates that your .htaccess file is either incorrect or not being processed. Please paste your .htaccess file.

    I’m not sure I really fully understand the difference or the interaction between Permalinks and Slugs, but I was following the recommendations on the following website:

    What is a “Slug” in WordPress? + Tips for a Great Post URL

    I edited the Slugs for my Pages based on the recommendations on the website above. I also changed the Permalink settings from Plain to “Post name” at which point I started getting the 404 error. When “Post name” is configured in the Permalink settings, I believe the Slugs are used on the end of the URL for a page (e.g. “/definitions/” in my earlier example) instead of the default (e.g. “/?page_id=100” in my earlier example).

    I’m not sure it makes sense to look at my .htaccess file at this point as I’m back to using the defaults for now and things seem to be working again, but I was hoping there was a high-level procedure for achieving my goal without resorting to manually editing the .htaccess file.

    I’m also wondering if my browser history data might perhaps be part of the problem versus WordPress and/or the Bluehost web server.

    Moderator sterndata (Steve Stern)

    @sterndata

    The guide you followed looks safe.

    It makes perfect sense to look at your .htaccess file, because 404s are not being handled properly.

    The Permalinks are being handled correctly now that I changed them back to “Plain”. I suppose it might be useful to compare the .htaccess file when Permalinks are configure to “Plain” versus the .htaccess file when Permalinks are configured to “Post name”, but I’m getting a bit nervous about messing any further with Permalinks at this point because I’m worried I might mess things up beyond recovery.

    I changed the Permalinks back and forth one more time earlier to investigate the answer for the question about the sample for the old and new links. After I changed the Permalink setting back to “Plain” the sample page I was investigating still gave the 404 error. I tried shutting down and restarting my browser but encountered the same problem. So I deleted my browser history data at which point the sample page I had been investigating started working again, which is why I think some of my problems might be related to browser history data.

    When I was investigating the 404 problem on various web sites, I believe I saw a warning on one of them that changing Permalinks when your server is running can cause 404 errors. So perhaps I need to shut down and restart my server when I change my Permalinks, but I don’t see anywhere to do that on my Bluehost account. My Bluehost account is the basic shared hosting plan, so perhaps if I contact Bluehost they might have a way to shut down and restart my portion of the server.

    Moderator sterndata (Steve Stern)

    @sterndata

    NO, the server does not need to be rebooted. There’s an issue with your .htaccess file.

    I changed my Permalink settings to “Post name” again, and looked in the root directory using the Bluehost cPanel File Manager and I don’t see any .htaccess file. I do see some other files that start with a period (e.g. .htpasswds), so I don’t think it’s a hidden file problem. I didn’t get any error messages when I changed my Permalink settings.

    I’ve seen some other sites that indicate I need to update my .htaccess file with redirects when I change my Permalink settings. I also found a tool that automatically generates these redirects, but when I ran the tool it indicated I didn’t need to do anything because it indicated WordPress would automatically generate the redirects for me.

    I’m wondering if my problems have anything to do with the fact that I disabled the MOJO Marketplace plugin to fix another problem which was a conflict with user registration (i.e. user’s always got a suspected bot message when trying to register).

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.
Skip to toolbar