Support » Fixing WordPress » Blue Questionmark – can't add media – EasyWebHosting

  • Resolved shelleywilsonart


    My web host is WebEasyHosting. I installed WordPress and all seemed great until I tried to upload an image to the media library. It showed up as a blue question mark. I’ve called the company and gone into chats with them. I’ve talked with the tech support and with the sales people (asked for a refund) and the same guy answers every time. I found another topic similar to mine. They said the web host person has to disable htaccess. The guy I keep talking to at the company seems absolutely clueless – to the point that I can almost envision him, a high school student, sitting at a little desk in his bedroom, in his parent’s house, with his one computer and cell phone – running a web host company.

    My site is here.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi there,

    Do you have an .htaccess file on your server? If not, it is easy to make one and upload it via ftp.

    Info about what info it should contain can be found in the WordPress Codex in the “htaccess” article.

    It also appears that your site is showing a SSL error. This problem may also be related to your htaccess file.

    The .htaccess file should show the following text:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    It doesn’t appear that I have an htaccess file on the server.

    You can create one in notepad (or any simple text editing program) and upload it via FTP. Make sure that the file is called .htaccess (note the period at the beginning).

    This should solve the issue. Here’s another thread about creating one, as well, in case that is helpful.

    I created the simple text, per your recommendation, but I don’t think I can use FTP to load it. Are you talking about something like DropBox? Can I go into my ftp files and create it in there somehow? If so, do I create a new file and at what level? Within the HOME level or public_html or within wp-content?

    I’m pretty good at figuring things out, even when they’re over my head, but this one is whipping me good.

    Don’t know if it will help, but when I try to view the image on your home page – this one:

    I get:

    An error occurred during a connection to SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

    Thanks. It just proves that not even that image worked correctly.

    Oh sorry, just reread this and Tom already mentioned the SSL problem – have you asked them about that specifically?

    Here’s some more info on .htaccess that may be useful:

    I’ve chatted with the web host. I’ve called them three times. I’ve talked with tech support and sales. The same person answers all calls. When I ask him about this issue, he is unable to help. He pretty much just leaves dead air on the line and eventually I say that I’ll keep trying to fix it on my own. He says, OK. Done. The account is paid up for a couple more years and they have no refunds at this point.

    I’ll keep trying the things you’re suggesting. I’m determined.

    It’s fixed!!! Amazing. I tried the chat option again with the web host. I wasn’t able to uninstall WordPress, but the tech guy was. I reinstalled it, selected http://www. for the beginning of my URL and that fixed it. Thank you for all your advice. It ended up being the option I chose (though I don’t recall what I chose – maybe it was https: instead of http:

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Blue Questionmark – can't add media – EasyWebHosting’ is closed to new replies.