Support » Plugin: LittleBot ACH for Stripe + Plaid » blue dot continues to pulse…

  • Hi Justin,

    The blue dot continues to pulse as if it were trying to process the transaction.Please advise.
    thank you
    Robert

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author justinwhall

    (@jwind)

    Hi Robert – IN order to help, I’ll need the following:

    1) Any errors shown in the browser console.
    2) Any errors printed to your WordPress debug log.

    Thread Starter robertflower

    (@robertflower)

    Ok

    1. I would need the errors from the user?
    2. I don’t believe there is a debug log, unless its the “Turn on logging” tick box. Which was not ticked.

    Please advise
    Thanks
    Robert

    Plugin Author justinwhall

    (@jwind)

    1) Yes, but the user can (and should) be you 🙂
    2) WordPress has a debug log. You can try enabling logging and see if it logs an error but to enable the WP logging: https://www.wpbeginner.com/wp-tutorials/how-to-set-up-wordpress-error-logs-in-wp-config/

    Lastly, can you send along how you have your settings configured. obviously not your API keys but the state of you environments.

    I’m running into the same problem. It doesn’t look like any errors are hitting your plugin’s log and the only errors that are showing in Chrome’s developer console are listed below:

    A cookie associated with a cross-site resource at http://cdn.plaid.com/ was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5088147346030592 and https://www.chromestatus.com/feature/5633521622188032.
    jquery-migrate.min.js:2 JQMIGRATE: Migrate is installed, version 1.4.1
    (index):1 A cookie associated with a cross-site resource at https://m.stripe.com/ was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5088147346030592 and https://www.chromestatus.com/feature/5633521622188032.
    wp-stripe-plaid.min.js:1 fired
    /wp-admin/admin-ajax.php:1 Failed to load resource: the server responded with a status of 500 ()

    Plugin Author justinwhall

    (@jwind)

    The server is returning a 500 error. Like I noted in the previous post, I’ll need the debug log to be helpful here. Otherwise I can only speculate. Are you sure all your API keys are correct?

    Thanks Justin,

    Will you send me steps to produce the log you’re looking for?

    Plugin Author justinwhall

    (@jwind)

    Sure, it’s posted above. Your PHP server logs will have error as well. You can ask you host for these.

    https://wordpress.org/support/topic/blue-dot-continues-to-pulse/#post-12252141

    So, the PHP log didn’t show anything, however; the debug log did.

    [18-Jan-2020 03:09:20 UTC] PHP Notice: Undefined property: stdClass::$stripe_bank_account_token in /BLANKED_OUT_FOR_SECURITY/wp-content/plugins/ach-for-stripe-plaid/public/class-wp-stripe-plaid-public.php on line 511
    [18-Jan-2020 03:09:21 UTC] PHP Notice: Undefined variable: current_user in /BLANKED_OUT_FOR_SECURITY/wp-content/plugins/ach-for-stripe-plaid/public/class-wp-stripe-plaid-public.php on line 358
    [18-Jan-2020 03:09:21 UTC] PHP Notice: Trying to get property of non-object in /BLANKED_OUT_FOR_SECURITY/wp-content/plugins/ach-for-stripe-plaid/public/class-wp-stripe-plaid-public.php on line 358
    [18-Jan-2020 03:09:21 UTC] PHP Notice: Undefined variable: meta_key in /BLANKED_OUT_FOR_SECURITY/wp-content/plugins/ach-for-stripe-plaid/public/class-wp-stripe-plaid-public.php on line 358
    [18-Jan-2020 03:09:21 UTC] PHP Fatal error: Uncaught Stripe\Error\InvalidRequest: Could not determine which URL to request: Stripe\Token instance has invalid ID: in /BLANKED_OUT_FOR_SECURITY/wp-content/plugins/ach-for-stripe-plaid/vendor/stripe/stripe-php/lib/ApiResource.php:119
    Stack trace:
    #0 /BLANKED_OUT_FOR_SECURITY/wp-content/plugins/ach-for-stripe-plaid/vendor/stripe/stripe-php/lib/ApiResource.php(132): Stripe\ApiResource::resourceUrl(NULL)
    #1 /BLANKED_OUT_FOR_SECURITY/wp-content/plugins/ach-for-stripe-plaid/vendor/stripe/stripe-php/lib/ApiResource.php(56): Stripe\ApiResource->instanceUrl()
    #2 /BLANKED_OUT_FOR_SECURITY/wp-content/plugins/ach-for-stripe-plaid/vendor/stripe/stripe-php/lib/ApiOperations/Retrieve.php(24): Stripe\ApiResource->refresh()
    #3 /BLANKED_OUT_FOR_SECURITY/wp-content/plugins/ach-for-stripe-plaid/public/class-wp-stripe-plaid-public.php(362): Stripe\Token::retrieve(NULL)

    Plugin Author justinwhall

    (@jwind)

    Hey Chaz – Are you logged in when this happens?

    This was from me testing in an incognito window.

    Hey Justin,

    I’m just following up on this. My client is hoping to be able to use your plugin soon.

    Thanks!
    -Chaz

    Plugin Author justinwhall

    (@jwind)

    I took a look and could not reproduce. I will circle back but sadly, since this plugin is free/doesn’t generate revenue, it has to come after those that do.

    The error indicates you have the same customer in more than one environment. Stripe doesn’t know which one to use. Have you tried with a difference email address – one that you have not used? Even a fake on is fine.

    Hey Justin,

    I’ve used a unique email each time I’m afraid and just tested another unique email that I haven’t used previously and experienced the same result.

    What else can I do to help you get this fixed? This is the only plugin that seems to meet this client’s needs. I’m hoping to not have to develop my own solution for this.

    Thanks!
    -Chaz

    Plugin Author justinwhall

    (@jwind)

    Are you positive that you are using the proper keys for the proper environments? It’s worth noting you have to apply to get a production (live) account with plaid. You can still make limited charges in “development” environment.

    If you are wanting modification to the plugin, the fastest way to get that done would be to contact me via my website and I’d be happy to talk about contract rates.

    Alternatively, short of developing your own solution, Pull Requests are accepted. https://github.com/justinwhall/ACH-for-stripe-plaid

    • This reply was modified 2 years, 5 months ago by justinwhall.

    I sent you a message from your website.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘blue dot continues to pulse…’ is closed to new replies.