Blogger/Blogspot Import (12 posts)

  1. dfwdraco76
    Posted 8 years ago #

    I just got WordPress set up and working on my domain (thelifeofbrian.info), hosted by websitesource.com (I'd have already updated to 2.5.1 if I could).

    One of the first things I tried was importing my posts from my Blogger/Blogspot blog... It all seemed to work fine - the first page of posts all showed up with images and everything. I was so excited!

    But then I tried going back to older posts - and nothing is working.

    My blog is at: http://www.thelifeofbrian.info/blog

    If you click on any of the items under Archives on the left, or on Previous Entries at the very bottom, or on the Archives link at the very top, it just says (for example), "Not Found. The requested URL /blog/page/2/ was not found on this server."

    Am I doing something wrong?

    I tried searching the forum for "blogger" and "blogspot" and "import" but it came back with nothing...

    Clearly I have some work to do getting everything set up before I can tell the world about my new blog. But it's pretty exciting getting started with WordPress. Thanks for your help!

  2. iridiax
    Posted 8 years ago #

    You are probably having permalinks problems. Here's one thing to try:

    Go to Dashboard -> Settings -> Permalinks and verify your permalinks settings. Click Save Changes even if you haven't changed anything.

  3. dfwdraco76
    Posted 8 years ago #

    wow, thanks for the quick response!!

    I found the setting you mentioned -- it's under Options | Permalinks. I have "Date and name based » http://thelifeofbrian.info/blog/2008/06/14/sample-post/" selected.

    I clicked "Update Permalinks Structure" and it came back with a message saying, "You should update your .htaccess now." I also noticed at the bottom it says, "If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all."

    I don't know where this .htaccess is located...

    I've discovered a similar problem in that I can't upload a picture for a post -- it tells me, "Unable to create directory [snip]/thelifeofbrian.info/blog/wp-content/uploads/2008/06. Is its parent directory writable by the server?"

    there was no uploads directory under wp-content so I created one, but it's still giving this error.

  4. iridiax
    Posted 8 years ago #

    WordPress support search is not working for me right now, so I can't look up to tell you exactly what to do, but...

    .htaccess is located in your blog folder on your website, and you need to add mod_rewrite rules to it (this is due to your web host's server settings).

    You also need to check your file permissions for uploads. Some people have had problems with this and end up just creating the year and month folders inside the uploads folder themselves. Who is your web host? Some people have had their web host fix this one for them.

  5. dfwdraco76
    Posted 8 years ago #

    I've just upgraded to 2.5.1... problem still exists.

    btw, now I can get to the permalink settings the way you descirbed. ;-)

  6. dfwdraco76
    Posted 8 years ago #

    web host is websitesource.com.

    I don't see an .htaccess file in my blog directory...

  7. iridiax
    Posted 8 years ago #

    You may need to contact your web host about this as it can be due to their server settings.

  8. dfwdraco76
    Posted 8 years ago #

    I just sent them an email. now I get to hurry up and wait for a reply... ;-)

  9. dfwdraco76
    Posted 8 years ago #

    is there anything else that should be in the .htaccess file, besides what WordPress is telling me:

    `<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]

    If not I could just create my own, right?

  10. dfwdraco76
    Posted 8 years ago #

    Ok I threw the contents listed above into a file called .htaccess and put it in my /blog directory, and now the original problem has been resolved. On to the next one... figuring out permissions for the upload directory.

  11. dfwdraco76
    Posted 8 years ago #

    Error I'm getting now when trying to upload an image (and it's difficult to see, btw - I have to copy it and paste it into a text editor to see it):

    DismissAn error occurred in the upload. Please try again later.

    I've granted write permissions to owner, group, and public. what am I missing? I'd rather not have to manually create a new directory each month...

  12. dfwdraco76
    Posted 8 years ago #

    can anybody help w/ my upload woes?

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.