Support » How-To and Troubleshooting » Blogger Import Error

Blogger Import Error

  • Hello, I’m running wp & I’m trying to do an import from Blogger. I changed the settings and I have the resulting wordpress.php in my wp install’s home directory, but when I go to the import-blogger.php file I get this error:

    Fatal error: Cannot redeclare upgrade_all() (previously declared in myurl/wp-admin/upgrade-functions.php:7) in myurl/wp-admin/upgrade-functions.php on line 6

    Any advice would be greatly appreciated!

Viewing 5 replies - 1 through 5 (of 5 total)
  • I can reproduce this error on as well… I have posted a message on the authors blog, I am sure he will come up with a solution. I have half an inkling to delete that upgrade declaration on line 6 but prudence says NO… keeping my fingers crossed and hope that the author can find a solution.

    If not, I will install the old 1.5 version, get my comments in, then upgrade to haha

    The problem is that the file import-functions.php is being required twice, when it should only be required once. I have searched the code and found no place that does this, but I don’t have any copies of to check.

    A workaround for you is to edit one line of import-blogger.php. Around line 19, change this:
    to this:
    and then try again.

    I can’t seem to be able to publish more than 5% of my blog (or so says blogger.com). I only see the last month in my WP directory.

    Any ideas as to why this happens?

    works brilliantly skeltoac… thank you so very much….

    adeco2: That is a separate issue that I have addressed in the very last update to this post.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Blogger Import Error’ is closed to new replies.