The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Blogger ate my RSS (6 posts)

  1. quietfm
    Posted 11 years ago #

    Yesterday I went to Blogger (my old tool) to disable the RSS feed from my old site. Unfortunately I forgot that Blogger was directed at my new wordpress site (Version 1.5). Both my RSS and Atom feeds are disabled.

    Here is the error message I'm getting on both feeds:
    The XML page cannot be displayed
    Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.
    Only one top level element is allowed in an XML document. Error processing resource 'http://quietfm.com/jcblog/wp-rss2.php'...
    I went to Feed Validator (as suggested by another post.)

    Looks like Blogger added another header to the feed on lines two and three of the feed. It looks like this:

    <b>Warning</b>: Cannot modify header information - headers already sent by (output started at /home/quietfm/public_html/jcblog/wp-blog-header.php:260) in <b>/home/quietfm/public_html/jcblog/wp-rss2.php</b> on line <b>10</b>

    Where do I go or what do I do to undo my bonehead error?

    Thanks. Nick

  2. quietfm
    Posted 11 years ago #

    I've continued to explore other postings, and am getting closer to the problem. The end of my rss2.php file does not end with the typical "?>" sign. http://codex.wordpress.org/Answers-Trouble_Shooting#Headers_already_sent

    My file ends with this:
    </channel> </rss>

    Should I eliminate all info on the file up the point where <rss> and <channel> appear?

  3. James Huff
    Support Team Rep.
    Posted 11 years ago #

    Just download WordPress again and replace your feed files with the ones from the fresh download.

  4. quietfm
    Posted 11 years ago #

    Thank you for the suggestion.

    Did the download, and it still doesn't work. Same error message. The downloaded wp-rss2.php file from WordPress also includes the </channel></rss> ending. Could there be any other files that could've been damaged or altered?

  5. James Huff
    Support Team Rep.
    Posted 11 years ago #

    I'm sorry, I was in a hurry earlier. It looks your problem is with wp-blog-header.php on line 260. Try replacing that file. Or, if you haven't upgraded to WP v1.5.1.2 yet, do so now.

  6. quietfm
    Posted 11 years ago #

    That's the one. Everything's working now. Thanks a bunch!

Topic Closed

This topic has been closed to new replies.

About this Topic