Support » Plugins and Hacks » BlogAds Widget non-op in 2.2?

  • Just upgraded to 2.2 today, and my BlogAds widgets are not working properly – I’ve got two paid for ads that ought to be running right now and they’re not. Instead I’ve got an empty “Premium Sponsor” box on both sidebars with no content.

    The “Premium Sponsor” rotator box isn’t even out of the tray on either sidebar – anybody have a clue?

Viewing 6 replies - 1 through 6 (of 6 total)
  • WordPress 2.2 now has natively, widgets–meaning you don’t need the Sidebar Widget plugin. So you will need to deactivate, if you are allowed, the Sidebar Widget, and delete any files in your plugin folder relating to the Sidebar Widget plugin.

    You’ll also want to know if your theme is 2.2 compatible.

    Yeah, I’ve noticed that – in fact it isn’t possible to activate the sidebar widget plug-in. But I was using the AdRotator widget/plugin to carry my BlogAds content in four separate “widgets” numbered 1-4. Now, no matter what html content is in the different widgets it shows the content from the #1 widget.

    Now, no matter what html content is in the different widgets it shows the content from the #1 widget.

    Known issue, discovered just after the release of 2.2.

    Download this patched file: widgets.php
    And place it at wp-includes/widgets.php (overwrite the normal one).

    This will fix the problem.

    Thanks!

    My problem is different. Widgets work find on my blog. But I cannot find a Blogads widget anywhere. I’ve tried pasting the Blogads code inside a test widget and inside a php widget, but the ads just do NOT show up.

    I do NOT want to manually past the code into sidebar.php.

    Any advice.

    It would seem to be in Blogads best interest to come up with a way to fix this, considering hos widespread widget use is becoming.

    Thought I’d bump this up a bit.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘BlogAds Widget non-op in 2.2?’ is closed to new replies.