WordPress.org

Support

Support » How-To and Troubleshooting » blog working weird?

blog working weird?

  • Hi check my site here: http://www.simplecandy.com/

    As you can see i use WordPress for the whole site, its working fine except the news page isnt work as a page, the news tab isnt showing as selected, and then titles isnt saying the page name. any suggestions why its not working like all the rest of the pages even though i have made a page.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Can you please paste the code for your navigation bar? Also, you do have content in that news page?

    <ul id="menu">
    <?php wp_list_pages('sort_column=menu_order&depth=0&title_li='); ?>
    		</ul>

    This is the code for the nav, as for the news page its just a page that is told to use the main index as a template and therefore display the typical blog stuff. Any ideas why WP isnt showing this a normal page for the title and nav.

    any updates?

    hello?

    Do you have a page template selected for the page?

    i have added the template code for giving them names to the index.php file in the theme, but WP knows to use index.php automatically anyways. i have made a news page and given the template as the news page ie index.php

    but its still not treating it as a page but rather an index. i cant create a new page and use the index.php code because that doesnt work.

    hey people this still isnt resolved? can u help

    Untill you give this kind of confusing statements…

    i have added the template code for giving them names to the index.php file in the theme, but WP knows to use index.php automatically anyways. i have made a news page and given the template as the news page ie index.php

    … I don’t think anybody would be able to help you.

    the templete code for those who don’t know is:

    <?php
    /*
    Template Name: NEWS
    */
    ?>

    So when i view this page it should be saying news page in the browser title and the nav should be selected. I want to know why?

    So when i view this page it should be saying news page in the browser title

    Wrong. You have to create a Page in the admin using this template and the title of your Page will be displayed in the browser’s title bar.

    Wrong. You have to create a Page in the admin using this template and the title of your Page will be displayed in the browser’s title bar.

    but that is what i have done?

    Well, “news” isn’t working as a Page – because it is selected to display your blog posts. Doing that its behaviour is changed.
    It seems selecting this option doesn’t display anything in the browser’s title bar, only the blog name.

    yeah i know! my q is how to fix this.

    I don’t think there is anything to “fix”.
    When you set up a Page to behave as the home/main/index – it will just do that. On a standard setup of WP when you are on the main index page, there is nothing in the title bar, except your blog’s title/name.

    Are their any other WP support forums cause i dont seem to be getting any fixes here.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘blog working weird?’ is closed to new replies.
Skip to toolbar