[resolved] Blog totally out after trying to customize twenty eleven (5 posts)

  1. Hazlo
    Posted 4 years ago #

    Hello everybody here,
    I guess I should not go into customizing a template before learning more about php, but I tried it however and now my blog is out with this message : "Parse error: syntax error, unexpected $end in /home/hazlotop/public_html/blog/wp-content/themes/hazlotheme/functions.php on line 302"
    I made a copy of twenty eleven in a new directory, and I called it Hazlo Theme (the path is: public_html/blog/wp-content/themes/hazlotheme). I installed it and started to work on it. It was ok
    up to the point where I tried to paste (into "functions.php") the following code (I found it here in the forum) in order to remove the "Home" button from the navigation bar :
    add_filter( 'wp_page_menu_args', 'tec_page_menu_args', 11 );
    function tec_page_menu_args( $args ) {
    $args['show_home'] = false; // no 'home' button
    return $args;
    Now I cannot even go to the dashboard to switch back to my ancient theme (utheme). However I can see on the server that all the folders are still here. I already edited the "functions.php file in my admin panel on the server, and removed the new added code, but it didn't help.
    Could someone tell me how to manage?
    Many many thanks in advance.

    here is the url of my blog

  2. Samuel B

    Posted 4 years ago #

    simply rename the /hazlotheme folder via ftp or host file manager
    this will let you log in and fix the problem

  3. Hazlo
    Posted 4 years ago #

    I did it. It worked!
    Thanks a lot Samuel. I can now switch back to my previous theme.
    This was my first big fear with WP!!!
    I'll be more careful now.....

  4. Samuel B

    Posted 4 years ago #

  5. Hazlo
    Posted 4 years ago #

    Thanks again Samuel for your help and advices.
    I've been finally able to create a proper child theme as explained.
    But till now i do hesitate with removing the home button. Think I've learned my lesson!..

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.