WordPress.org

Support

Support » How-To and Troubleshooting » Blog title integrates with Post title [:(]

Blog title integrates with Post title [:(]

  • Hi,
    I just upgraded my blog http://www.karthikk.net to WordPress 3 and applied the TWenty Ten theme. ANd now, the bots read my blog along with the title of the post continued by the blog title. Ex. if the title of the post is Create A professional resume, the bots read as Create a professional resumeKarthik.K’s Random Thoughts. Please help me! Urgent!

    Thanks!
    _
    Karthik.K

Viewing 8 replies - 1 through 8 (of 8 total)
  • that is the title tag of the mentioned post:

    <title>Create a professional Resume online | Karthik.K's Random Thoughts!</title>

    your bots seem to ignore the separator |

    you can change this in header.php ( the echo ' | '; parts in the following:

    <title><?php
    	// Returns the title based on the type of page being viewed
    		if ( is_single() ) {
    			single_post_title(); echo ' | '; bloginfo( 'name' );
    		} elseif ( is_home() || is_front_page() ) {
    			bloginfo( 'name' );
    			if( get_bloginfo( 'description' ) )
    				echo ' | ' ; bloginfo( 'description' );
    			twentyten_the_page_number();
    		} elseif ( is_page() ) {
    			single_post_title( '' ); echo ' | '; bloginfo( 'name' );
    		} elseif ( is_search() ) {
    			printf( __( 'Search results for "%s"', 'twentyten' ), get_search_query() ); twentyten_the_page_number(); echo ' | '; bloginfo( 'name' );
    		} elseif ( is_404() ) {
    			_e( 'Not Found', 'twentyten' ); echo ' | '; bloginfo( 'name' );
    		} else {
    			wp_title( '' ); echo ' | '; bloginfo( 'name' ); twentyten_the_page_number();
    		}
    	?></title>

    Oh! Thanks! I will try this out now! And post back the result! 🙂

    Hi,
    Im not able to find the echo ‘ | ‘. Here’s the code:
    http://pastie.org/1034389

    Line 21…

    wp_title( '|', true, 'right' );

    http://codex.wordpress.org/Function_Reference/wp_title

    Did that,
    But still, Google sees the same. 🙁 And also, check this: http://yfrog.com/mt6rlp

    mrmist

    @mrmist

    Forum Janitor

    Google wouldn’t necessarily reindex immediately, though.

    True! But then, If you can check that image, Its the Wp-user online plugin! And this problem exists for the past 5 days or so!

    Nothing seems to be fixing the problem! 🙁 Any udpates?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Blog title integrates with Post title [:(]’ is closed to new replies.
Skip to toolbar