WordPress.org

Support

Support » How-To and Troubleshooting » Blog suddenly shows blank page

Blog suddenly shows blank page

  • I’ve been running a WP blog for 3 years, and it has mostly run smoothly unless I did something to screw it up. Recently, the blog has started showing a blank page when navigating directly to “…/blog”, however if I go to an individual post, it works. The page won’t show up on refresh. However, I can still access the admin page, and once I do the blog will start working normally again for a little while, then revert back to a blank page.

    Does anyone have any ideas what could be causing this? Any help would be appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Use your FTP program to confirm you have an index.php in your /blog folder. If you do, open it up and make sure that it has the following content in it.

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wp-blog-header.php');
    ?>

    If it does, go to your theme folder and make sure that it has an index.php If it does, check to make sure it has the correct information in it. It may have been overwritten.

    index.php is present in both the /blog directory and the theme folder. both appear to have the correct contents. still the same problem. thanks though.

    More like a php memory problem. Ask you host to bump the PHP memory from 8M to 16M.

    Wanted to thank you for the posts. I just encountered this problem and have corrected it. I found to folders in the theme folder and uploaded my backup copies and it corrected it all.
    Thanks,
    Parrish’

    I have a similar problem, I accidenatlly zipped up everything in the wordpress folder when I unzipped the page was blank, but all looks correct.

    s’ok, I hadn’t unzipped wp-includes, working now

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Blog suddenly shows blank page’ is closed to new replies.
Skip to toolbar