WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Blog subscriptions widget excessive https requests

[Resolved] Blog subscriptions widget excessive https requests

  • Blog subscriptions widget is on front page,
    every time page is generated an request is made to uri https://jetpack.wordpress.com/xmlrpc.php?for=jetpack

    1) its remote
    2) its https

    and therefore is slow (adds at least 1 second), and because its made EVERY page generation (unless cached by object cache) it affects performance, thus doing too much remote requests isnt very nice for api server too.

    maybe add in future versions of jetpack an option to just display form for subcriptions and dont make any query for subscription status?

    http://wordpress.org/extend/plugins/jetpack/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Jeremy Herve

    @jeherve

    Jetpack Mechanic

    The subscription widget shouldn’t make so many requests. The widget indeed includes an option to display the number of subscribers on your blog, but this value is saved in a transient and cached for an hour, thus making sure that your site doesn’t make an outgoing request on every page load.

    If you do not want the number of subscribers to be displayed, you can uncheck this option in the widget settings under Appearance > Widgets in your dashboard.

    thank you for explantation, Jeremy
    I am using xcache object cache, but on switching to new theme xcache variable cache has been disabled, therefore seems transients caching wasnt working at all and this caused excess requests to be made on every page generation.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Blog subscriptions widget excessive https requests’ is closed to new replies.