Support » Fixing WordPress » Blog seems to have vanished! Empty page!

  • Resolved ripvils


    Help, please!
    My original problem was that I couldn’t create a backup of my blog. I got the error message “backup directory not writable”. So I came to the support forum, searched for a solution to that problem and found a thread where experts recommended changing the CHMOD settings of the wp-content folder.
    So I tried to apply this piece of advice. Using WS_FTP95, I accessed my remote WordPress folder, right-clicked on the “wp-content” folder and chose “CHMOD” in the context menu. There I clicked the “write” option for “Group” and “Other”, then clicked “OK”.
    When I returned to the browser tab where I had the WP-admin panel open, it said “page no longer valid”, so I logged into my wp-admin again … but there was no “backup” button any more – and – far worse – whenever I click on “view site” now or enter the blog URI in the address field of my browser, I get a blank, white page! My blog seems to have gone.
    Luckily, when I click on “manage – posts” the posts still seem to be there. But nothing is shown at the blog address. Neither can I access the wp-content folder via FTP any more (error message: “Permission Denied”).
    What can I do?
    I’d be most grateful for helpful advice.

    And another question: if backing up is such trouble – is it even worth it?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Well, if you can’t even access the folder via FTP, you may need to get help from your hosts support, they can reset the permissions for you.

    Something happened to your setup when you changed the permissions, usually it’s no trouble at all. WP is sending me my backups at fixed intervals, couldn’t be much easier than that.

    If it’s worth it? Only you can answer that one 🙂

    Thanks for your reply, Class. I’ve already tried to get in touch with the host support, I suppose they’ll do something about it in the morning.
    You said: “WP is sending me my backups at fixed intervals” – well, that’s what I’ve been trying to get WP to do for me, too. I clicked the radio button for “send backup to my e-mail address” – but still the message was
    “backup directory not writable” … Hm. Mysterious.

    What version of WP are you using?

    @dianev: I’m using WP 2.0.8 – because my host only offers MySQL 3.23.

    Did your host reply to you?

    I ask because there’s no reason that changing permissions on that one folder should have caused the problems you’ve detailed.

    Sorry for answering that late – I had forgotten about this post because yes, my host did reply, and the support team explained that it was due to a bug in my FTP program; they then told me which options to check (“execute” had to be on for all three columns). So I made this change – and, relief, everything was back to normal.

    I agree that it seems very odd for my changes to have the effects I described, but – well, it happened like that, and the problem went away after I had changed the permissions back.

    Thanks for taking interest in my problem!

    please tell us what the permissions settings ARE now that it is all working. I, too, have the same backup directory not writable message and today, suddenly, my v.2.1.1 install started showing a blank page for any of the public pages, though the admin pages work just fine. Oddly, when I look at the presentation admin page, it doesn’t show any themes, though the working theme with all files are actually there (and were working just fine up until 9:30am today)… I can ftp and I can see the files.

    What SHOULD the wp-content folder permissions be?

    As a rule of thumb, 644 for pages, 755 for directories.

    That’s a rule of thumb, not an absolute, as there are many ways to configure a web server and the process owner of said service…


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Blog seems to have vanished! Empty page!’ is closed to new replies.