WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Blog Roll not showing up

[Resolved] Blog Roll not showing up

  • I am having a problem with my Blog Roll. It wasn’t appearing on its own. So I added the code below. It works but it doesn’t look like the other lists of links, for example the Meta sidebox below it. The Blog Roll didn’t show up in the default WordPress theme so I was wondering if there is another way besides using the code below to get it to show up.

    The blog – sids.motd.org

    <div class="sidebox">
    <h1>Blogroll</h1>
    <ul class="sidemenu">
    <?php get_links(); ?>
    <li class="sidemenubottom">

    </div>

Viewing 2 replies - 1 through 2 (of 2 total)
  • Because that template tag that you are using does NOT put the items between <li> and </li>
    Read the documentation before posting:
    http://codex.wordpress.org/Template_Tags/get_links

    I think I get it but I am not sure…

    It’s not being displayed in an unordered list, even after using the docs you sent me to.

    Here is what I now have:

    <div class="sidebox">
    <h1>Blogroll</h1>
    <?php get_links(2, '<li>', '</li>'); ?>
    </div>

    Whenever I add echo to the end only the header of my blog appears.

    UPDATE!!: I got it working. I just needed to add the UL tags with a class defined. It was in an un-ordered list but wasn’t formated.

    Thanks for the link to docs 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Blog Roll not showing up’ is closed to new replies.