Support » Fixing WordPress » Blog posts not showing in feed

  • Resolved partynoparty

    (@partynoparty)


    We recently changed hosts and there has been some strange behavior on our blog page since. I suspect it is some kind of file permission issue but I’m not sure the best way to fix it.

    The issue:

    All blogs published after we changed host are not showing up in our blog feed. There are currently three that should be showing up in the feed that are not. The most recently published blog will appear at the top of the page, as normal. But when a new blog is published, it will not move down to the feed of recent posts.

    To make things more interesting, we are also using Ajax Load More for our blog feed. If you click the ‘show more’ button at the bottom of the feed, the plugin apparently does see and count the new blog posts, because however many blog posts are hidden (in this case three), it will duplicate that number of posts in the feed that are already showing in the list.

    So it seems to be that this might be a permission issue. And I can probably have my host change the permissions so that the new blogs will show. My concern is that all newly created blogs will be created with the same permissions, which means I would need to contact my host every time I publish a blog and ask them to change the permissions on the newly created blog post.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Were you able to solve this problem? I just checked your page and saw posts from today showing.

    Thread Starter partynoparty

    (@partynoparty)

    Yes, we were able to resolve. It turned out to be just be a caching issue. I had cleared the WP cache already, which did not help. But apparently I also needed to clear my browser cache….

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Blog posts not showing in feed’ is closed to new replies.