[resolved] Blog Posts Not Showing (13 posts)

  1. alphatucana
    Posted 4 years ago #

    I see lots of people having problems like this, but the fixes I've read don't seem to be fixing it for me!

    The site is http://www.websitetavern.com/saloon

    It is a nearly new WordPress install (I then upgraded it the next day as the latest version came out right then). I did some SEO Core Tweaks with that plugin then disabled it. I changed to ChocoTheme. I changed the permalink structure to /%category%/%postname%/ and I added Akismet and cbnet Ping Optimizer. Anyway, I deleted the original post and typed up my own. It isn't showing.

    I have tried:
    - deactivating all plugins (no effect)
    - default theme (no effect)
    - default permalink structure (this works)
    - confirmed that modRewrite is on
    - confirmed that the article is present in the database

    The alternative permalink structures don't work, only the default one works. WordPress complains that my .htaccess file is not writeable but it has 644 permission and is in my /htdocs/ folder (although my wordpress blog is in a /saloon folder, and I have tried it in either place and both places anyway). I put the code in there that WordPress asked for manually but it isn't working. I have a bit of extra code so www and direct to the domain amount to the same thing (for SEO purposes) but it doesn't work either way.

    What next? Any ideas? TIA

  2. kmessinger
    Volunteer Moderator
    Posted 4 years ago #

    The url is not good.

  3. alphatucana
    Posted 4 years ago #

    Do you mean the one in my original post? It works when I click on it... and I get the front page of the blog with a 404 not found error for the blog post. What result are you getting? Or do you mean the url to my post? That, indeed, is my problem in a nutshell.

  4. kmessinger
    Volunteer Moderator
    Posted 4 years ago #

    http://www.websitetavern.com/saloon - If this is supposed to be your blog, see http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    I think you have something in the wrong place or have set the site url wrong.

  5. alphatucana
    Posted 4 years ago #

    I see... that article though is for if I want WordPress to power the whole site. I only want it to power the blog, although I do want it in the /saloon subdirectory. I will read it through carefully as it's clearly relevant, but I'm not sure how much it will apply.

  6. alphatucana
    Posted 4 years ago #

    Currently under Settings > General I have a wordpress address of:


    and a site address of


    I don't want to put WP's index.php in the root directory as I have one of my own there. I don't know with my setup whether I should be changing that require('./wp-blog-header.php'); line in some way or not. To be honest, I just expected WordPress to work.

  7. kmessinger
    Volunteer Moderator
    Posted 4 years ago #

    WP just doesn't know where the files are.
    Change the index.php file to read require('./saloon/wp-blog-header.php');

  8. alphatucana
    Posted 4 years ago #

    OK, done that... Well, actually, it didn't work, but ../ on the front did - so in the end I just put the full server path down instead.

    However... the posts are still not found. Does the path have to be specified somewhere else as well? I've had a bit of a rummage around but haven't found where that might be.

  9. kmessinger
    Volunteer Moderator
    Posted 4 years ago #

    We need to go back to the beginning. First, WP does not work well with relative URLs. Use absolute urls if possible especially for meta data.

    I only want it to power the blog

    Put all of wp in the directory saloon. You don't have to have wp's index.php in the root but if you don't, you need to follow these instructions, http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    But why not let wp run the site? You can open on any Page you create in WP instead of the "blog" page.

    If you are using the ChocoTheme the css should be in themes/ChocoTheme/style.css not in /style/v2-wst-style.css. But in any event, the link to the style sheet should be absolute.

    Why are you using stats from http://statcounter.com/joomla/ ?

    There are also validation errors, http://validator.w3.org/check?verbose=1&uri=http%3a%2f%2fwww.websitetavern.com%2f

  10. alphatucana
    Posted 4 years ago #

    OK; I think all of WP is in /saloon. I'll go through those instructions carefully tomorrow evening maybe (I only get about half an hour a day to look at this problem - it seems as if nobody's tried to do this before, given how difficult it is to make it work!).

    In the long run it may be better to have WP running the site, but at the moment my mission is only to add a blog to an existing site; I don't have the time right now to rewrite the rest of the site and customize the template.

    At the moment the blog is using ChocoTheme but once it works I may customize it to match the rest of the site - or leave it, depending on how much time it'll take. Don't know. I'll make the link absolute, but it is working for now, I think.

    The stats are from the rest of the site's code. They're the last thing I'll fix. I'll have to fix the validation errors though, that's right. Thanks for the help so far, by the way! ;-) I'm sure we'll get to the bottom of it in the end.

  11. alphatucana
    Posted 4 years ago #

    OK, re:


    Everything was (and is) in place, except that index.php is not in my root directory because I already have one of my own there. Still getting 404 Not Found for the blog posts.


  12. kmessinger
    Volunteer Moderator
    Posted 4 years ago #

    Under settings general, put wp address and site address http://www.websitetavern.com/saloon

  13. alphatucana
    Posted 4 years ago #

    Yep, that's it! Working now.

    Thanks a lot for your persistence and patience!


Topic Closed

This topic has been closed to new replies.

About this Topic