Support » Fixing WordPress » Blog Posts Not Formatting Correctly on the Posts Page

  • Perac

    (@perac)


    Hello,

    I’m using the most recent version of WP and the Pinboard theme.

    My site is currently set up with a static front page (‘Home’) and a ‘Posts’ page.

    Right now, any blog posts appear on the main ‘Posts’ page without any formatting (no matter what I change in the WYSIWYG or html)… like this:

    Sample Post
    Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.

    However, once I click on the title of the post it brings me to a page for that specific post, and then it displays the formatting, like so:

    Sample Post
    Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut laoreet dolore magna aliquam erat volutpat.

    Ut wisi enim ad minim veniam, quis nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.

    I want the formatting to appear on both the main ‘Posts’ page and the page for the specific post.

    Unfortunately I can’t post the specific code because this site is supposed to be private until completed, but any suggestions would be welcome. Assume I know nothing about coding when making suggestions though, please, I’m new at this… 🙂

    Thank you all in advance!

Viewing 1 replies (of 1 total)
  • I do not use that theme, but I suspect that the blog page displays excerpts and not full posts. Excerpts by default strip out all formatting.

    The Advanced Excerpt plugin might work for you to allow formatting.

Viewing 1 replies (of 1 total)
  • The topic ‘Blog Posts Not Formatting Correctly on the Posts Page’ is closed to new replies.