Support » Theme: Vantage » Blog Posts No Longer Working

  • mainestarlight

    (@mainestarlight)


    When activating the vantage theme, I have now lost the links to the blog posts. See here: http://mainedeaffilmfest.com/2013blog

    The blog titles and “Continue reading” are now pushing to home.php which doesn’t exist. I must have done something wrong but I cannot figure it out. The posts show up on the page above, as you can see, however I am unable to visit each blog post. This may be a larger issue instead of a theme issue?

    Thanks for your help! Love this theme.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi there mainestarlight. I can’t be sure, but this looks like it could be a plugin issue. Can you try disabling your plugins one by one and see if deactivating any of them fixes it?

    Hopefully we can get this sorted out!

    Thread Starter mainestarlight

    (@mainestarlight)

    Hi Greg,

    Thanks for responding. I deactivated all of the plugins one by one and no such luck. I even deactivated them all and tried but it still does not work. Not sure what to do next?

    I did just do a test blog post and I’m thinking it now has nothing to do with the theme but wordpress itself? The blog post I set up as a test and posted it showed the permalink to be /home.php.

    I could get the shortcode which gave me the actual direct link to the blog entry. Thus, I just went into the permalinks settings and saw that it went to Custom: /home.php which is weird because I did not set it that way.

    And by writing this out, I have figured it out. Not sure if you’re theme had anything to do with this because I have never gone into that section????

    Thanks!

    I have a similar problem. My Blog page is “Blog”. For the front page, I want to use the Vantage (v1.1.2) Home page.

    If I go to WordPress Reading settings and select “Front page displays recent blog posts”, the Vantage Home page works, but the Blog page displays no posts.

    If I select “Front page displays A static page: Front page “–Select–“; Blog Page “Blog”, the Vantage Home page does not work. The Home page displays the blog; the Blog page displays the blog. The Vantage Home Page was automatically turned “OFF” when I saved the Reading settings.

    If I select “Front page displays A static page: Front page [select any actual static page] say “Directions”; Blog Page “Blog”, the Vantage Home page does not work. The front page displays the blog; the Blog page displays the blog. The Vantage Home Page was automatically turned “OFF” when I saved the Reading settings.

    In the failed state, if I go back and save the Vantage Home Page settings, the Reading setting automatically reverts to “Front page displays recent blog posts”.

    The desired state is the Vantage Home page works AND I can select a static page to display my posts.

    My workaround is to try to find a plugin with which I can filter posts based on category and use the plugin’s shortcode to display the posts.

    I have the same exact issue. Is there a solution to this?

    I am having the same issue as CraigSenior. I love having the front page feature the carousel of my most recent posts, but then the posts do not get posted to the blog page I set up for the same reason CraigSenior mention.

    Greg – Is there a solution for this? Other than this snafu, I love the theme and appreciate all of the other features. Thanks for you help!

    Here is a link to my site if it helps

    I think I have the same problem as mainestarlight – the Home page is perfect with the section ‘latest posts’ at the bottom of the page.
    I have set a new page ‘Blog’ as a Blog page template and added that to the main menu.

    Now Blog page is on the main menu bar, but when I click it my blog page just stays on the front page, with the URL ‘/blog/’.

    If anyone knows what I have done wrong, please help me!

    Found the solution – on the Reading Settings I selected “Blog” on posts page but chose ‘your latest posts’ on the front page displays and saved the change.
    Now the Blog page is working perfect!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Blog Posts No Longer Working’ is closed to new replies.