The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] blog posts / category links broken after upgrade to 3.4.1 (8 posts)

  1. theconsultant_
    Posted 4 years ago #

    Unfortunately i have upgraded onto 2 live sites, everything seemed ok, but unfortunately i did not properly test before compounding my mistake by upgrading on another site.

    I have disabled pluggins, flushed cache, reselected permalinks to no avail.

    Site 1
    Uses thesis 1.8.5 static pages are fine, and click through without problem. blog posts exist if i directly paste the url in the browser bar without problem. however if any category page links in my nav menu are 404'd

    Site 2
    Uses a themepress theme, which is quite heavy on category links. again the same issue. static pages re fine, category links are 404'd

    I have rolled back to previous backups ( 3.4.0) which seems to be ok, and ad reluctant to upgrade again to 3.4.1 until a fix / root cause determined.

    Does anyone have any suggestions? I've rolled back one site, would prefer to fix the issue on the other.

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

  3. Roy
    Posted 4 years ago #

    I'v seen quite a few similar questions since 3.4.1. There seems to be some conflict in the permalinks. Often default works, but 'pretty' not, also not without plugins and with 2011... I have no problems with it myself though.

  4. theconsultant_
    Posted 4 years ago #

    thanks for the assist esmi, will try ftp suggestion. theme and reuploaded already done without any success.

  5. theconsultant_
    Posted 4 years ago #

    esmi, you are a star! that seems to have done the trick and looks to be a plugin issue.

    1. downloaded Twenty Eleven ( i had deleted all themes apart from my present theme) and applied
    2. flushed cache ( use w3 total cache)
    3. disabled all pluggins.
    4. ftp into site. renamed plugin folder to plugin.hold
    5. flushed cache on browser, checked site
    6. renamed plugins.hold back to plugins
    7. log on back-end, reapply thesis theme.
    8. check site > category posts there!
    9. reactivate plugin > blog posts 404'd!

    At least now i have pinpointed a plugin is the cause. i'll drill through and see which one causes the breakage and update the thread.


  6. esmi
    Forum Moderator
    Posted 4 years ago #

    i had deleted all themes apart from my present theme

    FYI: Never, ever, delete the default WordPress theme (currently the Twenty Eleven theme). It's an essential safety net in many situations.

    Either way, I'm glad to hear that you now have a solid lead to investigate. If all else fails, you could try another cache plugin such as http://wordpress.org/extend/plugins/wp-super-cache/ I don't usually need a caching plugin but, if I did, that's the one I would go for, personally.

  7. theconsultant_
    Posted 4 years ago #

    WordPress SEO is the culprit. I carefully reactivated all my plug-ins ( 20 in total) wordpress seo broke it again.

  8. Ciprian Tepes
    Posted 4 years ago #


    thanks for the tip. I was having the same problem with the permalinks and I didn't know what to do. As soon as I deactivated the wordpress seo plugin everything worked like a charm!


Topic Closed

This topic has been closed to new replies.

About this Topic