Support » Fixing WordPress » Blog post photos not showing on mobile devices

  • Resolved angel357

    (@angel357)


    I am having a problem viewing photos on mobile devices.

    If I view the blog on a tablet or a computer the photos show correctly. However if I view the blog on a mobile phone they disappear. Does anyone have a possible solution for this. Thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Try deactivating plugins to explore whether any could be responsible.
    Try looking at the theme’s demo website on a mobile phone to see whether the issue is specific to your theme.

    angel357

    (@angel357)

    I have tried to deactivate the plugins. The theme is a custom theme I created based off of Twenty Twelve. They were showing fine when I first took the blog live. I tested it and all my photos were showing

    Yesterday, a visitor pointed brought this to my attention and sure enough when I tried viewing it on my phone the photos were missing.

    Could it be a media query hiding them?

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Rather than us throwing out wild guesses, link the site in question for us to diagnose.

    angel357

    (@angel357)

    310designs.com/blog

    The problem is only on blog posts.

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    I don’t see any images on my laptop for this blog post.

    angel357

    (@angel357)

    Great so now none of my photos are showing regardless of what device they’re viewed.

    atlanteavila

    (@atlanteavila)

    Your problem is in the css: style.css line 897:

    .intro img {
    			visibility: hidden !important;
    		}

    Not possibly you hid them to save bandwidth on mobile devices?

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    I blame the CSS that specifically tells them to be hidden.

    angel357

    (@angel357)

    I have fixed the issue so that photos are again visible on tablets & computers.

    That’s hiding a specific class which is for an image I want to have hidden. It shouldn’t affect every photo in posts.

    angel357

    (@angel357)

    I just gave it a try and that was the issue. Thanks guys!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Blog post photos not showing on mobile devices’ is closed to new replies.