WordPress.org

Forums

Blog paging and multisite (14 posts)

  1. spikelms
    Member
    Posted 1 year ago #

    Hello,
    I am having an issue where the built in paging to my blog (displayed on my homepage) isn't working. The blog section of the template displays the 4 latest blog posts. The bottom part of the section auto generates pages to the other blog posts only when a user clicks to see any of the other posts it just refreshes the homepage.

    The site is hosted on Windows Azure, running WP Domain Mapping (Azure mandates) and is a multisite. I've contacted Azure techs and they can not duplicate the issue.

    Here's the URL for my site: http://www.letmommysleep.com/#s_blog1
    Here's how it's supposed to work: http://turcuciprian.com/preview/WP/Lana/blog-multiple-column-styles/#s_blog2

    Any insight into what may be going on is greatly appreciated.

  2. Does it work with a diffneret theme?

  3. spikelms
    Member
    Posted 1 year ago #

    Not sure. It's built into this theme.

  4. Pagination is a part of almost every theme - go try another one.

    I suspect the issue is the theme.

  5. spikelms
    Member
    Posted 1 year ago #

    I will give it a shot.

    I tried setting the permalinks to default and not postname and the paging worked then. But as soon as I turned it back to postname the paging quit working.

  6. spikelms
    Member
    Posted 1 year ago #

    I created a subsite and used a plain install of the same theme I am using in the problem site and the paging worked fine. So it can't be the theme.

    In the test subsite I had none of the plugins activated that I have with the problem site. I tried deactivating certain plugins but had no luck finding out which one, if any, could be affecting it.

    Any other leads to run down would be appreciated.

  7. Web Guru
    Member
    Posted 1 year ago #

    it's not an issue, it's just your themes functionality which shows your posts as bound to .... just check with some other theme first.... hope it will help

  8. I created a subsite and used a plain install of the same theme I am using in the problem site and the paging worked fine. So it can't be the theme.

    No. Check with the default theme. TwentyTwelve. Stop using the theme you know isn't working :)

  9. spikelms
    Member
    Posted 1 year ago #

    Thank you both for your replies! I will check with 2012. Is there a specific page I can bring the paging part up? On a cursory review of the 2012 site I did not see auto paging.

    Stopping using the theme that isn't working is a little more easily said than done with 3 months of development time already put into this project. :)

  10. You already created a subsite - Test there :)

    On a cursory review of the 2012 site I did not see auto paging.

    Well now that brings up the question of what YOU think auto-paging is. I think it's 'My site shows numbers at the bottom to list how many pages there are in an archive.'

  11. spikelms
    Member
    Posted 1 year ago #

    Ah, there is a dis-connect here. Apologies. I am a simple graphic designer and not a PHP programmer or developer of any kind. The site template I am using has that feature built in, I did not create it, just taking advantage of the piece that already existed. If other themes have the feature built in (2012?) I would like to test them to see if the template I purchased is at fault or if it's something else like a plugin or the hosting.

  12. The site template I am using has that feature built in

    What feature, though. Was my explanation correct?

  13. spikelms
    Member
    Posted 1 year ago #

    That would be correct. The part of the homepage (link above) that shows the blog entries (set to show 4 posts) auto generates the number of pages a user can scroll through and clicking on said numbers refreshes the page to the second, third, etc. page.

    Eg. -- << (1) (2) (3) >>

  14. Okay, well as I'm using a theme that does that myself, I know for sure that 'WP' is fine, and this is likely a theme problem :/ If the problem doesn't happen on single site, then it's something in the code that's written wrong, or reinventing the wheel for this pagination, in a poor way.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.