Support » Theme: Responsive » blog page translation

  • Items placed in responsive / core / includes / functions.php are not translated by the theme.
    In French I replaced them hard in the code, but I must later have several languages ​​on the site.
    How to correct this?

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Theme Author CyberChimps

    (@cyberchimps)

    Hi,

    Can you please let me know which texts are not being translated ?

    Thanks.

    Hi
    i haven’t look all text, but i speek about “Posted on”

    Thx

    Theme Author CyberChimps

    (@cyberchimps)

    Hi,

    I checked your page http://maquette.pasapattes39.org/actualites/ and there is a translation for the “Posted on” text. Is your issue resolved?

    Thank you.

    No, as I said in my first post, I changed it directly in the code for the moment

    lopale

    (@lopale)

    Hello,
    I tried to activate the main theme and not the child, but the phrase does not always translate. The problem does not come from the child theme.

    st3phan5

    (@st3phan5)

    hi all,

    the same problem in german. I just checked the files.

    It’s file core/includes/functions.php line 468 (ver. 3.7) … The part to translate uses in the php-file an <i>…</i>-tag (for awesome calendar icon). This is missing in the pot-language file. Just exclude it from this line to print it one line before. There is nothing to translate with this icon. Works fine.

    I hope that this was the problem. greets!
    /st3phan

    code I used (hope that printf is okay ) on line 468:`
    printf( __( ‘<i class=”fa fa-calendar” aria-hidden=”true”></i>’));
    printf( __( ‘<span class=”%1$s”>Posted on </span>%2$s<span class=”%3$s”> by </span>%4$s’, ‘responsive’ ),`

    • This reply was modified 8 months ago by  st3phan5. Reason: added code
    lopale

    (@lopale)

    actually if we delete the icon it works.
    Thank you
    But that means modifying the function file that will be overwritten any update, and also that non-English languages can not have this icon.
    It should be rectified

    st3phan5

    (@st3phan5)

    @lopale

    there is no need to delete the icon-part. Just separate it from the part to translate, as I wrote above (code example).

    you ‘re right, that this will be overwritten with the next update. Theme authors have to fix it in their code for future use/the next update.

    I haver use the same technique as you write.
    It’s perfect, but, please CyberChimps, change this for the update.

    Thanks st3phan5

    Theme Author CyberChimps

    (@cyberchimps)

    Hi all,

    I checked the issue on our test server but unable to replicate it.
    I tried installing the WordPress in French language and then checked the Blog page. The “posted on” text is getting translated properly.

    Can you please let me know how you have set up the blog page – Is it from setting–>Reading or from the page template?

    Thank you.

    Hello,
    for my part I had configure the blog page via configuration -> Reading.
    But the problem was also present on the page of a single news
    Thank you.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘blog page translation’ is closed to new replies.