blog page / static page problem after move of WP directory (2 posts)

  1. elarson
    Posted 7 years ago #

    I had my site located at http://www.mysite.com/blog. I created a static front page and a blog page for posts it worked fine (version 2.7).

    I then moved the entire WP blog directory to the root directory http://www.mysite.com/. Now I can not access the blog page. All other pages work fine.

    I've searched all over and can't seem to find anything that works. I'm desperate -- please help!

  2. elarson
    Posted 7 years ago #

    I think I finally solved this. I made a permalink to the blog page at www.mysite.com/index. Now the blog page and all static pages work in WordPress 2.7.1.

    I think the situation I had is quite common. I had a web site at http://www.mysite.com with a directory www.mysite.com/blog that contained the WordPress installation. I then decided to put the entire web site in WordPress to use it like a CMS at www.mysite.com/.

    Here were my steps (this site is using WP in Dutch, so I hope I got it right for English):

    - I used the documentation at http://codex.wordpress.org/Moving_WordPress to move the blog to the root directory www.mysite.com/

    - Using Administration > Pages > Create New, I created:

    -- a "Hoofdpagina" ("Home" in English) page with a permalink http://www.mysite.com/hoofdpagina/
    -- a "Blog" page with a permalink http://www.mysite.com/index/.

    -- Both pages use the default "kubrik" page template without modifications.

    - Using Administration > Settings > Reading. I selected:
    -- Front page displays
    -- A static page (select below)
    --- Front page: Hoofpagina
    --- Posts page: Blog

    - In my menus I linked:
    -- Hoofdpagina ("Home" in English) to <a href="/index.php" title="Hoofdpagina">Hoofdpagina</a>
    -- Blog to <a href="/index/" title="Blog">Blog</a>


    - I don't like the following in browsers, but can live with it:
    -- The blog is shown as http://www.mysite.com/index/
    -- The Hoofdpagina (Home) is shown as http://www.mysite.com

    - Some older posts on this forum talk about modifying templates, but I did not get this working and it should not need to be done in WP 2.7.

    - I found it useful to use the "kubrik" default theme to get this working before dealing with other template issues.

    - I have no idea if this had anything to do with moving my WordPress installation to http://www.mysite.com/blog to http://www.mysite.com/

    - I had to fix all image paths, but that had to do with moving the blog, rather than the problem with the static front page.

    - I happen to be using Spry menu's, but this should not matter.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.