WordPress.org

Support

Support » How-To and Troubleshooting » Blog only in seleceted Page

Blog only in seleceted Page

  • I want to create blog only in a particular page.

    In my website there are several pages (Home,About Us,Contact us,Blog etc.)

    I would like to create blog posts only under tha “Blog” Page.

    Is it possible??

    Is there any way where i can give access to registered users of my site to write under the “Blog” page only??

    Any help would be highly appreciated.

    Thanks in Advance

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi Virus,

    In Dashboard/Settings/Reading you can select the page Blog for your posts and then you must set another page as the static front page.
    And yo should allready have created a page (not post) with the name “Blog” before you can select it. This page has to be empty, it only needs the title, which will show in your menu.

    Users: wordpress standard knows about 5 user levels with different rights. And if none of these fit your wish, there are many usermanagement plugins.

    Thanks Dude.

    But the problem is when i create a new post then the right side of the template items are messed up and the screen goes to right

    Too bad, but without a site link and a themename it’s hard to say anything about that new problem.

    site link: http://www.nrbvoice.org/blog

    it is the default template.

    Hi,

    Your template is custom made for you and not the WordPress Default theme.
    Next, I see no shifting but I get a 404 error when I click “Blog”

    Try resetting your permalinks to the Default setting , hit save and see what happens.
    After, that (when it works) set them back and try again (don’t forget to check the .htaccess editing mentioned at the bottom of that screen).

    Now i am getting 404 Error which redirects to server default page and i tried to create the custom structure again but it is not working

    Hmm, the only difference I see is that in your right-nav the link to Blog is like /blog/ and the other page-links there are full url’s, i.e. http://www.nrbvoice.org/career
    Why is that? Do you set the links in your theme options screen?

    Next, why is the Blog page link not showing in your top-menu?

    In general: first get it working with default permalinks, if then eveything is OK (and make sure you have at least one post) then consider changing the permalinks.

    I tried to create a post and then change the permalink.Nothing changed despite having 404 error.
    please see the snapshot.

    [img]http://xs.to/image-6448_4B9710B4.jpg[/img]

    Well, I see a blogpost now!
    But in the blog view your footer is shifting to the right.
    Validation shows that you are missing a </div> somewhere.
    http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fwww.nrbvoice.org%2F

    How can i solve this issue?? none of my blog posts are appearing properly 🙁

    I created another testblog page http://www.nrbvoice.org/testblog and that is also the same (footer Shifts to right)

    You copied from the original so you also copied the errors in the coding that create this effect.

    You have to get rid of the errors.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Blog only in seleceted Page’ is closed to new replies.
Skip to toolbar