Support » Theme: Primer » Blog not showing full text in Mins theme

  • Resolved Infiknit

    (@infiknit)


    In settings – reading, I have set the blog to full text, but it still not showing as full text. Thanks you

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • HI @infiknit,

    It looks like the theme just generates an excerpt, regardless of the reading setting that you have specified.

    What you can do is increase the excerpt lengths to display the full text, however the HTML will be stripped from the excerpt – so if you have a YouTube embed, a slider, images etc. they won’t display.

    You can add the following little code snippet into an MU plugin that you create which will increase the excerpt length to 300 words.

    add_filter( 'excerpt_length', function($length) {
        return 300;
    } );

    If your content is longer than that, you can bump the value up to a larger number.

    We can certainly take a look for a future release to see what we can do to allow for the full post content to display based on that setting. I’ve created an issue on our Github issue tracker so that I can track this moving forward:
    https://github.com/godaddy/wp-mins-theme/issues/60

    Hi @infiknit

    Just following up here – I’ve taken a closer look and that setting you are referring to actually controls the excerpts of the RSS feed and not the excerpts on the blog itself.

    You’re best bet is to alter the length of the excerpts using the filter provided above. That can be placed inside of a custom MU plugin that you create. We have some documentation setup on how to achieve that, here.

    Evan

    Thread Starter Infiknit

    (@infiknit)

    Creating a MU plugin is beyond me. I also wanted to change the MINS theme to storefront and I don’t seem to be able to do that. Storefront isn’t offered, when I search themes. I want to change themes to overcome this blog problem.

    I’m really not impressed with the Go-Daddy themes. I want a theme that will show all my blog posts fully – not just excerpts.

    Can you not change the MINS theme and then I can just do an update and have my blogs show the full content pictures and all?

    Hi – I’m having the same problem and I can’t believe it’s not possible to fix this easily. Can’t you just replace the posts template page with one that works correctly and give it to us?

    @infiknit If we update the theme then everyone using this theme will also receive those breaking changes and will wonder why their themes have been updated to show the full blog post content.

    The best option is to create the MU plugin and use the code above to increase the excerpt lengths, or to use the following code to replace the excerpts with the full content.

    /**
     * Replace front page blog posts with full content
     *
     * @param  string $excerpt Post excerpt.
     *
     * @return string Full post content.
     */
    function blog_post_full_content( $excerpt ) {
    
    	if ( ! is_front_page() ) {
    
    		return $excerpt;
    
    	}
    
    	global $post;
    
    	return $post->post_content;
    
    }
    add_filter( 'the_content', 'blog_post_full_content' );

    If creating an MU plugin is outside of your wheelhouse, you can also use a plugin that allows you to add custom code snippets without editing any files directly.
    https://wordpress.org/plugins/my-custom-functions/

    As for installing the Storefront theme, you can head into ‘Appearance > Themes > Add New’ and search for ‘Storefront’. There is nothing in the theme or anything on the GoDaddy hosting platform that would prevent you from doing so.

    Evan

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Blog not showing full text in Mins theme’ is closed to new replies.