Support » Installing WordPress » blog main page only listing directory contents, posts throw error 500

  • Resolved RobLifford


    Yesterday I ran Dreamhost’s 1-click upgrade from WordPress 2.0 to 2.0.1. All looked well, the autoresponder email said it was successful, I ran the wordpress upgrade.php, that claimed success too. I clicked around the blog a bit, all was normal, I logged into the admin area and confirmed that it was running 2.0.1.

    I moved on to other things and hadn’t touched the blog since then, but now I’ve been informed that it’s a bit of a mess. When I hit /blog/, it’s simply listing the directory contents:

    If I hit a permalink, it’s throwing the 500 internal server error page:

    The wp-admin area still seems to be working fine. I tried drafting a new post, and the preview iframe is showing 500/internal server error page too.

    The rest of my site, outside the /blog/ directory, seems perfectly normal. In fact, the homepage of the site, outside the WP install, calls blog/wp-blog-header.php and uses a WP plugin function to do a random tagline, and that’s working fine too.

    So WTF could be going on here? I’m wondering if this has something to do with the automated upgrade, or if there’s some unrelated problem on the server end, or what.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Possible lead? Went and checked the error log and I’m seeing an awful lot of this:

    [Sun Feb 26 18:48:05 2006] [error] [client] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error.

    I know the only place on the site that I’d be using mod_rewrite is for WordPress’ permalink structure. So I snagged the .htaccess file from my WP directory, and here it is, but I can’t tell yet if something’s wrong with it…

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]

    # END WordPress

    Never mind. Looks like I simply deleted the index file when I deleted the readme!

    Hey, we all do insanely dumb things once in a while, right? ;^)

    Yeah, some of us (can anyone say MOI?) more than once…. glad it’s sorted, couldn’t help you much anyway, don’t know anything about dreamhost….

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘blog main page only listing directory contents, posts throw error 500’ is closed to new replies.