Support » Theme: Author » “Blog” link on page links to an empty site

  • Resolved locomotionprogramming

    (@locomotionprogramming)


    I ran a few updates on my site which has the “Author” theme, but after adding a new blogpost i noticed that the “Blog” page is empty. If you navigate using the main page link or click on the author name, you get all the blog posts correctly. Is this a fault with the theme?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Theme Author Ben Sibley

    (@bensibley)

    I’m not aware of any bugs that would affect the blog page in this way. Could you review your settings in the Reading settings menu? It looks like the “Blog” page may not be assigned still as the “posts page.”

    locomotionprogramming

    (@locomotionprogramming)

    Seems like you pointed me in the right direction. After testing some variations of the settings found in Settings -> Reading -> “Your homepage displays” I have found something that may be unintended behaviour.

    My original problem came when I selected “Your latest posts” instead of “A static page”. This caused my blog page to go blank. But i also noticed that if i chose “A static page” with both the homepage and posts page as “Blog”. Then the homepage and blog link actually pointed me to the “Contact me”. So there is something going on there. I did see the warning “Warning: these pages should not be the same!”, but you should not allow it at all if you know that it causes bugs.

    So I have kinda fixed my problem, but I don’t see a way for me to have the Blog page as homepage without doing some bigger changes to the site.

    Theme Author Ben Sibley

    (@bensibley)

    Thanks for sharing these details. This feature is a built-in part of WordPress, so it is not a feature I can modify and control with the Author theme.

    That said, if you select the “Your latest posts” option in the Reading settings menu, this should display all of your posts on the homepage of your site.

    locomotionprogramming

    (@locomotionprogramming)

    I guess that would work as long as i removed the link “Blog” which does not work when I use that setting. Thanks for the quick response and help!

    Theme Author Ben Sibley

    (@bensibley)

    You’re welcome 🙂

    We have a tutorial on customizing menus that you may find helpful for editing the links in your sidebar too.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘“Blog” link on page links to an empty site’ is closed to new replies.