Support » Fixing WordPress » Blog go poof – Blank screen in Firefox, “bad server response” in Safari

  • I installed WordPress 3-4 weeks ago. I installed plugins, themes, and massaged the look of it and then I pretty much left it alone…until yesterday. I didn’t change anything to it, I just navigated to the page as a user would. It rendered fine and everything looked good. Then I clicked on a link to one of my pages (the About page that WP automatically creates, with the body text changed). This is when the fit hit the shan. Since then I can’t access any part of my blog, not user side or the admin or login pages. We’ve been trying to troubleshoot and debug code to find out what the problem is but if anyone has any ideas that might make this go a bit smoother, it would be greatly appreciated.

    Here’s some other information:
    – Here’s the link to the blog:
    – I do not use a commercial host, it’s in-house (literally, the server is in my basement)
    – I’ve looked through other “blank page” links on this site and found a resolution related to the wp-cache plugin, this was not one of the plugins that I installed

Viewing 5 replies - 1 through 5 (of 5 total)
  • What is your php memory set at? 16M may be a resolution.

    It was previously at 8, and we upped it; I believe to 16 but at least to 12. In addition, php-error messages are enabled; when it was 8 the problems we got were an error, now we just get nothing.

    Furthermore, if I put something like:
    near the very beginning of the first page, I _still_ get nothing.

    But if I put require(‘foo’); later on (causing a page crash) then I get all the messages I printed before the php error.

    More notes:
    Firefox (Mac or PC) just gives a blank page.
    Safari gives
    “Safari can’t open the page “”. The error was: “bad server response” (NSURLErrorDomain:-1011) Please choose Report Bug to Apple from the Safari menu, note the error number, and describe what you did before you saw this message.”

    After removing all plugins, a theme, and having touched a bunch of files, having changed the template and style to “default” (by manually accessing the DB) the front page still doesn’t load, but now the login page loads, and I get:

    Notice: Undefined variable: _SERVER in /www/jess/public_html/blog/wp-settings.php on line 31

    Notice: Undefined index: SCRIPT_NAME in /www/jess/public_html/blog/wp-settings.php on line 44

    Notice: Undefined index: PHP_SELF in /www/jess/public_html/blog/wp-settings.php on line 48

    Then I get the login window. I can login, but it says “insufficient privileges”

    I’m not sure how to fix this, but I have some hope that fixing this would make other things go away.

    On the main page, I’ve added various print() statements to try to trace it out. I removed the flush() statements because they didn’t ever help and occasionally conflicted with a Location header in pluggable.

    What I’ve done is that if I print the values coming into do_action in plugins.php, and selectively throw a require-error depending on the value that comes in. I’ve found that if I throw an error on or earlier than set_current_user, then I see all my prints. If I throw an error _after_ set_current_user, I see nothing. So I believe that whatever the problem is that makes the whole page blank is happening during do_action(‘set_current_user’)

    Of course, the actual problem may be much earlier… but I never successfully return anything to the browser if I let that part execute.

    We have lots of programming experience, some PHP experience, but are totally new to WordPress. Am I correct that moving a theme up to a directory like “wp_content/themeno” successfuly disables it? Likewise for a plugin?

    If it successfully loads after I’ve removed the plugin’s PHP files, and then it turns out that a particular plugin wasn’t the problem, are the settings for that plugin retained in the DB, or does something go delete them?

    System is SuSE Linux, Apache…

    Update again:

    The Notice _server bit was a red-herring. Based on some other research I added:
    auto_globals_jit = Off
    to php.ini

    This eliminated the notices. However, eliminating the notices means the screen is now blank again – instead of having the login page.

    That’s right – the PHP warnings were the only thing making the page display.

    I’ve also ran into this problem when I tried to upgrade from 2.0.6 to 2.1.3 (Yes, I should update more). Running upgrade.php from the command line gave the following errors…

    PHP Notice: Undefined index: SCRIPT_NAME in /var/www/html/wordpress/wp-settings.php on line 30
    PHP Notice: Undefined index: SCRIPT_NAME in /var/www/html/wordpress/wp-settings.php on line 43
    PHP Fatal error: Cannot redeclare the_permalink() (previously declared in /var/www/html/wordpress/wp-includes/link-template.php:5) in /var/www/html/wordpress/wp-includes/template-functions-links.php on line 4
    Content-type: text/html
    X-Powered-By: PHP/4.3.9

    I didn’t have the time to spend diagnosing this issue and my databases wasn’t touched so I backed out 2.1.3 and instead upgraded to 2.0.10 which worked perfectly despite having the same code in wp-settings.php.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Blog go poof – Blank screen in Firefox, “bad server response” in Safari’ is closed to new replies.