Support » Fixing WordPress » Blog Down and not Tech Savvy Enough to get it back up

  • I updated my blog to 4.2.2, I believe on May 6. On May 7, the blog was down with the following error message displayed when I clicked on the link:

    Fatal error: Call to undefined function _wp_scripts_maybe_doing_it_wrong() in /data/9/1/18/76/1344402/user/1441285/htdocs/wordpress1/wp-includes/functions.wp-styles.php on line 112

    I called Network Solutions, who host my site (www.elliecastellanos.com) and they told me they have nothing to do with wordpress problems, and directed me to these forums. I’ve read through everything I think is related to the problem and specific error message, but most of it is Greek to me. I don’t know what FTP is, and I tried manually downloading the zip file of 4.2.2 to try to update the site, but I didn’t get very far. I downloaded the zip file but couldn’t figure out what file to open to “unzip” it.

    Any advice for a layperson on how to get my blog back up?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi mamacastellanos,

    First you will need to contact your hosting again or check your email to see if they’ve ever provided FTP credentials for you. Or some hosting companies have FTP on their own websites for you to use. FTP (file transfer protocol) is just a fancy program for you to be able to physically see your files on a server (online) where you can then do what you like to them as in edit, move them around, whatever’s needed.

    If your hosting doesn’t have FTP on your hosting account dashboard, they should definitely have credentials you can use and you can download a free FTP software. I’m not sure whether you have a PC or Mac, but I user CyberDuck and Fetch. Also hear FileZilla is good too.

    Once you have this program, you’d log in with the provided credentials and you can then see your actual files. Usually it’ll be in a www folder or a folder with your hosting account username – it really depends on how your hosting company set it up. Now this is where you’d need to troubleshoot your site. The PHP error you’re getting is probably due to your theme or a plugin.

    The first thing I’d do is de-activate your plugins. If the problem goes away, one of them is the culprit. You’ll know by re-activating them one by one on your dashboard to see if the problem comes back.

    The second thing I’d do is activate a Twenty-Thirteen/Fourteen/Twelve etc. theme on your dashboard and see if the error is still there. If it is with plugins off, then it’s something in your theme.

    You can also debug by editing the wp-config.php file using your FTP. More about that here.

    Using the debug feature might reveal more errors to help you hone in on what is really the problem. I usually fine that when I get an error pointing to a wp-includes/ or wp-admin folder, it doesn’t actually have to do with those folders, but something in the theme or plugins I’m using. And so if the only error you get points to wp-includes/wp-admin, this might not help but it’s worth a try if you’re willing to give it a try.

    You don’t need to revert if you don’t want to since that sounds like what you’re trying to do via the FTP and trying to update with a zip. If your site is already updated, manually updating isn’t going to help unless your update went haywire part of the way. But it sounds like the update went fine and it’s just something broke after the update, correct?

    Depending on your issue, you’d either need to just replace or update bad plugins (which you should make sure those are all up to date too because that might also be the issue) or need to post here again once you have a better idea where the error is coming from.

    Also here’s the Common Installation Problems for WordPress as well as Common WordPress Errors. Hope that helps!

    So I managed to log onto my account, but the page looks very different than usual, and when I try to do anything I either get error messages like ” Fatal error: Call to undefined function _wp_scripts_maybe_doing_it_wrong() in /data/9/1/18/76/1344402/user/1441285/htdocs/wordpress1/wp-includes/functions.wp-styles.php on line 154″ when I tried to upgrade jetpack (which it said I needed to do) or things are blank, like for instance it doesn’t show I have any plugins at all, so I can’t deactivate them.

    When I tried to change theme I got the following error ” Fatal error: Class ‘WP_Customize_Theme_Control’ not found in /data/9/1/18/76/1344402/user/1441285/htdocs/wordpress1/wp-includes/class-wp-customize-manager.php on line 1222″

    It won’t really let me do anything at all, but I suspect that you’re right that upgrading won’t really help since I upgraded right before everything went haywire.

    I’m stymied.

    You can also upgrade plugins by looking for them in the WordPress plugin repo, downloading them, and replacing their folders in the wp-content/plugins folder if you can’t do it via the dashboard.

    Make sure all plugins are deactivated when upgrading either on the dash or manually as I suggested with FTP.

    What WordPress theme are you using? And which theme did you switch to?

    Thanks for your help, but I’m afraid you’re talking over my head and ability level. I did figure out that “repo” means repository, but I couldn’t figure out much beyond that.

    Basically, if I’m just a nincompoop with a blog, am I screwed here? Will I need to hire someone to help me de-bug the blog, or is there a chance that this could somehow resolve itself?

    I’m guessing that I’m screwed.

    That’s fine, I once didn’t know what repo stood for either. There’s things we don’t know, including myself, but I’d like to try and help if you’re willing to continue.

    Unfortunately if you prefer for someone to just complete the task for you however or do it with you side by side, then yes, you will likely have to hire someone for their time. Remember to never share your credentials or FTP with anyone unless you’ve hired them to help you and you’re confident they’re a trustworthy source.

    If not, then you can try and resolve it on your own. I understand it can be overwhelming.

    What steps have you completed so far?

    You can also find out if your hosting company has backups – I know my hosting company regularly backs up my site so it’s possible that they can just revert the site back to a week or so ago. They should be able to provide that much if they are a good standard hosting company. That would revert the site in both the files as well as the database – in other words, everything will be reverted including the upgrade and your site content.

    Thanks, RachieVee, for offering to help!! I would of course rather learn something and try and figure it out for myself than pay someone to do it, so here’s my process so far.

    1) Went to Network Solutions (my hosting service) and restored site from older versions. This didn’t effect my WordPress blog, as they informed me that they are two distinct entities.

    2) If I were to go to plugin repo to try and restore my plugins in order to deactivate them, would I have to remember which plugins I had in the first place? Because I’m sure I don’t remember. Just for the sake of argument, however, I’d like to try this process on one plugin that I know for sure I had–Jetpack.

    So I go to the link you provided, and click on Jetpack, which appears at the top of the page. I see across the top tabs that one of the options is “Installation”. When I click on that it says, “Install Jetpack either via the WordPress.org plugin directory, or by uploading the files to your server.”

    So, the logical next step, since I can’t use the WordPress.org plugin directory, is to upload the files to my server. Where do I find these files?

    Thanks again for your help.

    So the site is an older version now? What version is it? It’s probably a good idea to make a record of it from this point forward.

    As far as the plugins go, you can see what plugins you have with your FTP, just log in and look for wp-content/plugins folder. Then you’ll see the names of the plugins but you won’t necessarily know which ones you had active at the time.

    You can download the files from WordPress.org and on your FTP- replace the plugin folder in wp-content/plugins with the version you downloaded. If you already had Jetpack, you’ll most likely see that the folder you downloaded has the same name as the one already installed.

    If your site is an older version, and you’re unable to do the plugin test where you de-activate all plugins because Jetpack is breaking things, you can manually de-activate plugins on your FTP by re-naming all of the plugin folders to something else. If you want to make it easier on yourself, you can name them with underscores in the beginning so it’s easier to change it back.

    e.g. _akismet, _jetpack, _whatever

    This will de-activate them on the dashboard forcefully because the name change will make WordPress lose track of it.

    From that point when you overwrite Jetpack with your downloaded version, you should only be dealing with Jetpack being active.

    You can also just re-name the current Jetpack with underscores like I suggested and just drop your downloaded folder right in.

    If the problem is Jetpack, then with Jetpack active by itself, the errors will still be there. If the problem is not Jetpack, then your Jetpack fix with your now older WordPress should be fine. You can also test again by having Jetpack alone active, and switching to a Twenty-something theme. If everything works fine on that theme switch, then the issue might be your theme itself not getting along with Jetpack.

    Once you’ve gone through that process with Jetpack, you can repeat these troubleshooting steps with other plugins.

    Hope that helps! 🙂 This tutorial at the section where it says “How to update plugins manually using FTP client” might be useful as well. Good luck!

    Ok, here’s where I am now.

    In order to even use FTP with Network Solutions, I have to pay $30 to get the Fetch app, according to Network Solution’s website.

    So I can pay $30 to attempt to do something that I’m not even sure I can do on my own, or I can pay Network Solutions $60 to clear up this mess.

    I’m going to start calling around this week to look into switching hosting companies. I hear good things about arvixe, so I’m going to see if maybe I can kill two birds with one stone by getting a new host and maybe getting my blog up and running at the same time.

    Thanks for your help, though.

    I hear FileZilla is free if you want to go that route and figure it out on your own.

    I do agree on looking into other hosting options as well – the fact that they’re charging to reverse your site from a backup is not ideal. For hosting suggestions, I like WP Shout’s Hosting Article for 2014.

    I hope everything was resolved. Good luck. 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Blog Down and not Tech Savvy Enough to get it back up’ is closed to new replies.