"blog" directory (6 posts)

  1. gnormids
    Posted 5 years ago #

    Hello, I've searched around and I can't find an answer

    I've installed my blog in my root directory and activated the multisites options.


    When I created a post, the post url is


    Yes, I've activated Numeric Options in the permalinks.

    I don't want that BLOG directory, have no idea where it came from, I just want to keep it as


    Any help will be appreciated.

    _ _ _
    THis problem doesn't appear when multisites is off

  2. You can't turn it OFF right now. You can change it (edit the options for that site, it's in there). But in order to make sure you don't have name collisions, blog posts end up in /blog/ for your main site in a multisite install.

  3. gnormids
    Posted 5 years ago #

    This is what I did:

    I change from

    "domain.com/blog/archives/postid" to


    via super admin > sites > site > edit.

    In my post, the permalink says that my post url is: "domain.com/main/archives/postid", whatsoever, I click the link and the page doesn't exist. Doesn't work with /blog/main either

    In the Permalink Settings, I have activated the Custom Structure options, and it appears as: /blog/main/..

    Still, a problem :/

  4. Alan
    Posted 5 years ago #

    I just have /%postname% for my main blog and it works but I remember having problems getting rid of the /blog/ bit..

    Are you changing the permalinks in the

    Settings > Permalinks
    Super Admin > Sites > Site > Edit

    I can't remember the one that did it but I played around with both and got rid of it eventually..

  5. gnormids
    Posted 5 years ago #

    I just checked the p.links options.

    I still have it as "blog/main...", but even when I tried to enter a post via "blog/main/archives/postid, still doesn't work and the post doesn't exists. I tried to access via "posts > posts > view" and doesn' work either.

    In my permalink options, I have it as "Custom Structure", and the "blog" part, I can't change it. I'll set it as default and try again, and see if I can change it.

  6. gnormids
    Posted 5 years ago #

    Ok. I realised something. It doesn't work with "main", but it does with some other names.

    What I did was to do it backwards. I deleted everything but "postid", I got


    A added the rest

    domain.com/archives/postid, then


    and so far, it worked. Wonder why it doesn't work with the main, though.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.