WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] blog defaulting as landing page

[Resolved] blog defaulting as landing page

  • shauna@rbrand.ca
    Member

    @shaunarbrandca

    ARG!

    I am trying to get a blog page to act as a blog page (which it has been doing very happily for ever) but since upgrading to a new theme, the blog entries are not showing (except in preview mode from the edit blog page), and rather the blog page is acting as the landing page. So not only is the blog articles missing but when I try to activate my slider it wants to appear on the blog page.

    When I go into settings>reading> the static page and posting pages are all set up correctly, as are the templates for both the home page (welcome) and the blog page.

    I am really hoping some code wizard out there can hep me identify what to change:

    http://www.allthatglittersbook.com

    Thanks sooooo much, My head is hurting from slamming it into a wall!

Viewing 6 replies - 1 through 6 (of 6 total)
  • shauna@rbrand.ca
    Member

    @shaunarbrandca

    When I reset the settings / reading menu and make the FRONT PAGE DISPLAY > latest posts, then the blog is visible, but the same unnamed page (which is un-editable) now appears as my landing page.

    I have now tried to deactivate all plugins and reset all permalinks, and I still can’t get my home page to be the landing and the blog to be the blog!

    kmessinger
    Forum Moderator

    @kmessinger

    Have you checked here, http://www.studiopress.com/support/ ? As a premium theme Genesis is not supported here.

    shauna@rbrand.ca
    Member

    @shaunarbrandca

    Yes I realize that.

    I am unable to get support there. Even though the theme platform was purchased (by my client for over $300!) there is no free support (although it is advertised as unlimited support). THey don;t even have email or phone support it’s forum or bust and we have no access to the forum without buying more.

    kmessinger
    Forum Moderator

    @kmessinger

    Ir you are following this, http://codex.wordpress.org/Creating_a_Static_Front_Page and it does not work it is likely a setting in Genesis. I will add your theme name to the tags. Maybe someone with Genesis will be able to help. You should also search on the web for solutions.

    Andrea Rennick
    Moderator

    @andrea_r

    Even though the theme platform was purchased (by my client for over $300!) there is no free support (although it is advertised as unlimited support).

    There is support for the user who purchased the theme. 🙂 The $300 price tag was for the entire suite of themes, and that does come with support – for your client. They have to upgrade their forum account. Saying there is no support for a paying customer simply is not true.

    For the blog page setting do not use the Settings -> Reading blog page setting. Set that one to nothing.

    Make a page called “blog”. Apply the blog page template.

    If you have more questions, get your client to post in the SP forums, or see if they will let you use their forum account.

    shauna@rbrand.ca
    Member

    @shaunarbrandca

    Hi Andrea, your right!

    I had all log in info from my client, but the forums wouldn’t allow me access any post threads… There was a few days of frustration, and we have since re-logged in and got new access into the forums, by upgrading the clients account, I read the upgrade info incorrectly and thought they were asking the client to pay an addition $200 for support.

    In any case. I created a new blog page (with the blog template) and deleted the old one, and everything worked fine after that.

    Thanks for your help: kmessenger & Andrea

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] blog defaulting as landing page’ is closed to new replies.