Blog Completely "Gone" after 2.5 Upgrade (27 posts)

  1. datonn
    Posted 8 years ago #

    Hi all!

    First post in the forum...which is a good sign, meaning that I've had VERY few problems using WordPress over the past six months.

    I upgraded from 2.3.3 tonight to 2.5, then after I carefully copied all of the files out of 2.5 to overwrite my old 2.3.3 files (taking care to NOT overwrite the critical files that needed to be preserved), I went to log in and upgrade the site, and the site is simply gone. Blank white screen...no errors or even page source! Just a "Done" message in my browsers when I try to load the site or login to the WordPress admin info (hosted on my web host's server space).

    My host users MySQL version 5.0.45, and PHP version 4.4.7. The only thing I can think of is that I might not have logged out of the WordPress site admin one of my browser tabs before installing and uploading the new files on to my host server. Could that have messed things up?

    I've never had a problem upgrading versions before, but as of now, I have ZERO blog...so I would appreciate any help people might be able to offer. Thanks!

    Derek - http://www.graphicsoptimization.com/blog/

  2. datonn
    Posted 8 years ago #

    Edited to add:

    It DOES occasionally give me a bare-bones login/password info set in a browser window, but when I enter my login and password info, it re-directs to the following URL:


    Still completely grounded, and unable to login to my WordPress Admin info.

  3. datonn
    Posted 8 years ago #

    After reading a few more other threads, I thought I would try and delete the wp-admin folder off my web server and then re-load it, just to try and shake-out a few cobwebs and hope. That still did not correct the problem. Ugh. I'm sure it's probably an easy fix, but I'm grounded until I figure out what's gone wrong.

  4. Keilya
    Posted 8 years ago #

    Actually the uprgading instructions actually said to DELETE (not OVERWRITE) the old files (except those listed not to delete) completely and then re-upload the new ones.

    Also, seeing how you cannot access your Admin Panel as of now, trying backing up all the plugins file on your computer and deleting them off the server to see if it helps. I'm not sure whether you are aware but all plugins must be disabled before upgrading (well hope you did!).

    That's all from me...I'm not that pro but plugins were my main cause when I experienced a blank page.

  5. datonn
    Posted 8 years ago #

    Thanks for the ideas, fantasycrusader, but I'm still stuck with a blank white screen. Tried to completely delete all of the plugins off our web server, as well as re-installing plugin fills to the server after that didn't work. Neither task lets me even see the ability to enter a login and password to access the dashboard. My next step today will be to completely remove the entire "/blog/" directory off my web server, then re-install everything from scratch. So much for the "five-minute" update for WordPress 2.5.... :-(

  6. Jeff Sherk
    Posted 8 years ago #

    Whenever I do an upgrade, I use FTP (FileZilla).

    I deactivate all the plugins.

    I then upload the new WordPress right over top of the old one (I don't delete anything except hello-dolly.php in the plugins directory). The only file that I'm aware of that needs to be preserved is the config.php file, but there usually shouldn't be one in the new WordPress to overwrite the old one.

    Once the upload is complete, you goto http://.../blogname/wp-admin/upgrade.php and it will make any necessary changes to the database and you should be good to go.

    I would suggest you re-download WP 2.5 from the WordPress site and then re-upload it over top of whatever is on your site to make sure all the files got transfered properly.

  7. Jeff Sherk
    Posted 8 years ago #

    If it still doesn't work after you try re-doing WP 2.5 I suggest going back to WP 2.3.3 until further troubleshooting can be used.

  8. a666
    Posted 8 years ago #

    I think its a problem with THEME or HTACCESS, try to remove them temporarily to see if it works, plus clear your browser cookies and cache.

  9. a666
    Posted 8 years ago #


  10. Matt
    Posted 8 years ago #

    I've had blank-page problems with pre 2.5 WP installs after upgrading, and it's usually been a problem with a theme. As in: no theme is active. 8-|

    If you can't get to your admin page, get into the db however you normally do (command line, phpMyAdmin, etc) and set the theme to the default theme.

  11. datonn
    Posted 8 years ago #

    Thanks for all the suggestions, everyone! Since posting my initial "S.O.S." I have also gotten in touch with my web host as well. I use vDeck to manage files and such with them...and they told me today that they have been having significant problems related to MySQL and the recent 2.5 roll-over as well. They claim they are working on it...although sometimes that means it could take DAYS for me to hear back from them.

    In the interim, I am curious to learn how I could set a "default" theme and see if I can solve the problem myself. Quite honestly, the only time I go within a ten-foot-pole's reach of MySQL at all is when WordPress is giving me problems related to upgrades (twice now, but the first time was a minor glitch). Even when I try and login to MySQL via vDeck, no luck. I think I am probably out of luck until my web host gets MySQL and 2.5 to play nice with one another...though if anyone can share other ideas and/or more specific instructions for re-setting my site's theme (I use a significant hack to the wuhan-03 theme), I would greatly appreciate it. Thanks!


  12. Matt
    Posted 8 years ago #

    Does your host offer phpMyAdmin?

  13. datonn
    Posted 8 years ago #


    Truthfully, I don't even know. I am VERY good at coding and image optimization (one of the very-best when it comes to optimizing imagery)...but make me have to deal with database administration when it comes to web development, and I am about as far from being an "expert" as they come. :-) WordPress is great because they make it pretty simple to blog using MySQL or ??? without really having to understand how it works behind the scenes. That is, unfortunately, until something "breaks."

    I don't see "phpMyAdmin" within my "Control Panel" of options available to me in vDeck. I am hoping to figure out a way in if I can...as it might take my web host days to get to the bottom of things on their end, as opposed to hours. I was connecting just fine with 2.3.3 though, pre-upgrade to 2.5. With all the problems I have experienced, however, it makes me wish I would have hung on to 2.3.3 for a while longer...

  14. rhm94611
    Posted 8 years ago #

    I have one question for you? Did you by any chance "backup" your wp-config.php file? If you did, upload it and see if things work. If you wrote over that file or somehow deleted it - wp can no longer access your database.

  15. datonn
    Posted 8 years ago #


    Thanks for the suggestion. That was one of the first things I tried last night...making sure that my wp-config.php file was not missing, damaged or overwritten. It looked the same to me as before, so I assumed this wasn't the problem. However, the contents of that .php file can be found below (with me obviously removing account-sensitive information):

    // ** MySQL settings ** //
    define('DB_NAME', '**********'); // The name of the database
    define('DB_USER', '**********'); // Your MySQL username
    define('DB_PASSWORD', '**********'); // ...and password
    define('DB_HOST', '**********'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix  = 'wp_'; // Only numbers, letters, and underscores please!
    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    /* That's all, stop editing! Happy blogging. */
    define('ABSPATH', dirname(__FILE__).'/');
  16. Matt
    Posted 8 years ago #

    Ok, let's assume phpMyAdmin -- or any db administration -- is not possible.

    Get your old wp backup folder and upload it to your server at the same folder level as it was. Rename it "wp-old" before uploading so that you don't upload over 2.5.

    Then access your WP admin panel -- yourdomain.com/wp-old/wp-admin/ -- via your web browser and set a theme.

    Disregard all this if the 2.5 db is significantly different enough to make this exercise impossible, i.e.: use of 2.3 web files with 2.5 db.

  17. datonn
    Posted 8 years ago #


    Here's an example of how I need people to "dumb it down" for me. :-) I have a back-up file, but it has a .sql extension. I think that means that I only have a back-up of the database of info that I've been adding to the blog, so I'm not even sure your "wp-old" advice will work.

    All I want/need to be able to do is to get this blog working again. VERY frustrating...especially now that my web host's upgrades to MySQL are completed and I still get nothing but a blank page with the following URL replacing the blog home when I try and visit the site: http://graphicsoptimization.com/blog/wp-admin/upgrade.php?_wp_http_referer=%2Fblog%2F

    I REALLY need help. I appreciate those who have tried to help me to this point, but I think people might have to "dumb it down" for me a bit more in order for me to dig my way out of this hole that I seem to have dug for myself when innocently trying to upgrade to 2.5 on Sunday...


  18. datonn
    Posted 8 years ago #

    A quick follow-up.

    I downloaded a copy of WordPress 2.3.3 and uploaded all of those files into a "blog_old" folder (as intellivision suggested). I then entered http://graphicsoptimization.com/blog_old/wp-admin/ and got a login/password window after a bit. I attempted to then login, but after several minutes, my browser told me it would be unable to complete the request. I also tried http://graphicsoptimization.com/blog/wp-admin/ and couldn't even get a login/password window...as it would re-route me to http://graphicsoptimization.com/blog/wp-admin/upgrade.php?_wp_http_referer=%2Fblog%2F

    I am about at my wit's end with this...as this is the first time in 3-4 upgrades with WordPress that I have experienced any problems. The only difference with the upgrade this go-around is that I think I forgot to logout of my "admin" connect in a tab in Firefox before uploading all of the 2.5 files to the server.

    I am wondering if anyone knows how I might perform the upgrade step(s) at the MySQL level, since the URL route isn't working. It seems as though there should be 1-2 other methods for getting around this upgrade problem...I'm just not smart enough related to MySQL to figure it out. My blog is grounded though...until I can get a bit more help here. My web host basically said "S.O.L." related to the 2.5 upgrade and tech support...so you folks are about my only hope!


  19. datonn
    Posted 8 years ago #

    Another quick update: without any more suggestions, I threw in the towel and went back to 2.3.3. That seems to be working just fine, although I am disappointed that I haven't been able to get 2.5 working for my blog. I'll leave this as unresolved for now, as I'll try and get 2.5 working again at some point in the future.

  20. callaweb
    Posted 8 years ago #

    Don't know if this will help at ALL... but, I had some trouble with the "Maintenance Mode" plugin... I used that when I upgraded, but when I tried to go to the link http://.../blogname/wp-admin/upgrade.php the screen was blank! So, I had to go in and manually delete the maintenance mode plugin from my FTP, then retype in the upgrade.php and it was fine.

    Just a suggestion... ???

  21. Keilya
    Posted 8 years ago #

    In the interim, I am curious to learn how I could set a "default" theme and see if I can solve the problem myself.

    Ack...I would tell you that but I don't have the exact instructions for the 2.3 version. But it should be something easy to see such as "Themes" or something similar. It's "Design" in 2.5.

    Click it and the default theme will be there for you to choose.

    I was connecting just fine with 2.3.3 though, pre-upgrade to 2.5. With all the problems I have experienced, however, it makes me wish I would have hung on to 2.3.3 for a while longer...

    If you're talking about the 0.0.1 upgrades, they don't really require a change in databses that's why.

    When I visit this page of yours: http://graphicsoptimization.com/blog/wp-admin/upgrade.php?_wp_http_referer=%2Fblog%2F

    I don't get a blank page, in fact I get this message:

    Can’t select database
    We were able to connect to the database server (which means your username and password is okay) but not able to select the graphics_wp_1 database.

    Are you sure it exists?
    Does the user graphics_wp_1 have permission to use the graphics_wp_1 database?
    On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?

    If you don't know how to setup a database you should contact your host. If all else fails you may find help at the WordPress Support Forums.

    Can you open up your cpanel and check if the SQL user graphics_wp_1 has permissions to do EVERYTHING (write, read access etc. There should be a checkbox for "all".) to the database?

  22. Jay Mayu
    Posted 8 years ago #

    guys i'm getting a error mesg

    Warning: Invalid argument supplied for foreach() in /home/mayuonli/public_html/blog/wp-includes/classes.php on line 92

    in my home page http://mayuonline.com/blog

    I can't access single page.. it returns 404 error... fed up with WP 2.5

  23. Jay Mayu
    Posted 8 years ago #

    My prob solved...
    I got da same prob while upgrading to WP 2.5!!!
    Later I come to know from Ravidreams dat it's a theme related issue.. use Cutline 2.1 by Chris Pearson and David Peralty.
    It's a solution for this problem!!!

  24. spiff06
    Posted 8 years ago #

    Well, isn't that a pain...

    I've upgraded WordPress many times, don't think I did anything differently this time. Yet I have the same issue, first really big issue ever with WordPress.

    My header image is gone off the blog (yet it points to the proper file location, and the file is there, plain to see, in FileZilla and shell). Moreover, the page and footer background, found in the exact same location, with exactly the same permissions, do show up...

    The admin section doesn't find the CSS file at all, nothing at all shows up in Firefox's WebDeveloper plugin as far as linked CSS content, which might be normal because it's (now?) a php file reference (angle brackets changed):

    [link rel='stylesheet' href='http://blog.site.com/wp-admin/css/global.css?version=2.5' type='text/css' /]
    [link rel='stylesheet' href='http://blog.site.com/wp-admin/wp-admin.css?version=2.5' type='text/css' /]
    [link rel='stylesheet' href='http://blog.site.com/wp-admin/css/colors-fresh.css?version=2.5' type='text/css' /]

    The top and bottom links show CSS data, but the second link gives me a File not found warning message. If I type in .../wp-admin/wp-admin.css (instead of .../wp-admin/wp-admin.css?version=2.5), I get proper CSS...

    The last thing I remember doing is browsing around in the admin section and noticing that there was an option to revert to the legacy colors, tried it, didn't like it, then reverted.

    Does anyone know what's been causing this? I've been very trusty of WordPress upgrades, never had any glitch.

  25. spiff06
    Posted 8 years ago #

    All right, so the culprit is wp-includes/general-template.php (line 1113):

    function wp_admin_css_uri( $file = 'wp-admin' ) {
    	if ( defined('WP_INSTALLING') ) {
    		$_file = "./$file.css";
    	} else {
    		if ( 'css/colors' == $file || 'css/colors-rtl' == $file ) {
    			global $_wp_admin_css_colors;
    			$color = get_user_option('admin_color');
    			if ( empty($color) || !isset($_wp_admin_css_colors[$color]) )
    				$color = 'fresh';
    			$color = $_wp_admin_css_colors[$color];
    			$_file = $color->url;
    			$_file = ('css/colors-rtl' == $file) ? str_replace('.css','-rtl.css',$_file) : $_file;
    		} else {
    			$_file = get_option( 'siteurl' ) . "/wp-admin/$file.css";
    	$_file = add_query_arg( 'version', get_bloginfo( 'version' ),  $_file );
    	return apply_filters( 'wp_admin_css_uri', $_file, $file );

    I fail to see how adding ?version=2.5 (which is what the line before last does) helps in this instance. Looks like it conflicts with the .htaccess mod_rewrite options. I commented out the line, now I have a clean administration area.

    I renamed my header image and updated the css accordingly, now everything is (mostly) fine.

    Only glitch left, the dashboard doesn't update the incoming links, plugins, or development blog boxes. I also have three JavaScript JQuery errors, which are probably related. Sounds like something went wrong, and that I need to reinstall my blog from scratch... EDIT: The errors disappeared on browser restart. Might have been some cached files.

  26. spiff06
    Posted 8 years ago #

    Wham. Top banner image gone again, even with the changed name. And the CSS file for the admin section gives me a 404 even without the ?version=2.5 now. Something's going on on my server.

  27. spiff06
    Posted 8 years ago #

    Mmmh, turns out it was Firefox's browser cache. Everything seems to be fixed by clearing the cache in Tools -> Options -> Privacy -> Private Data -> Clear now...

Topic Closed

This topic has been closed to new replies.

About this Topic