WordPress.org

Support

Support » How-To and Troubleshooting » Blog by mail, base64 output of picture

Blog by mail, base64 output of picture

  • Hi! I’ve setup the blog by email, and it works almost fine.

    [1] When I send an e-mail with a picture as an attachment, it only outputs the subject as title (as it should) but nothing else. Neither the textcontent or the picture is added to the post.

    [2] When I send an e-mail with a picture as inside element of the e-mail it outputs the base64 rubish in the post and not the picture.

    [3] When I send an e-mail containing just text, it outputs everthing, but it does not support scandinavian letters like æ, ø and å.

    What can I do about these problems? Anyone figured it out?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Ok, I have looked through the wp-mail.php that parses the incomming e-mail. I seems it does not handle the part of the e-mail where the attachment is. This is marked as follow:

    Content-Type: image/jpeg; name=SAMPLE.JPG
    Content-Transfer-Encoding: base64
    X-Attachment-Id: f_evgab3fh
    Content-Disposition: attachment; filename=”SAMPLE.JPG”

    Is there any new versions of this file (wp-mail.php) out?

    I thought the wp-mail.php hack that several people have used in this fora would help me, but I can’t seem to find the file. On the authors homepage, the link to the file is rotten. (http://blade.lansmash.com/?p=156).

    Does anyone have this file? Does it work properly?

    Jay Holtslander
    Participant

    @jasonh1234

    Did you find a solution?

    I need a solution too…

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Blog by mail, base64 output of picture’ is closed to new replies.