WordPress.org

Support

Blog Broken

  • I am sorry to title this so oddly…but I honestly do not know how else to describe it…perhaps utter frustration and anger?

    I have somehow managed to change the characterset to UTF-7 instead of 8 and I think this is part of the problem.

    I seem to have broken something, as some of the charaters in posts are no longer appearing right…breaks in lines are not appearing right. When I click to edit on posts or comments, there is NOTHING there???

    I’ve tried to switch it back to the recommended 8, but it will not save the change. In fact, it won’t save ANY changes I make…I am SO frustrated!!

    My blog is here: http://www.luckylibra.com/bloggy/

    Although the content of the second entry is not suitable for “everyone” its got the best example of text issues. A few down is a MEME that has lost its format…its all run together.

    Anything I click, any changes I try to make, they are not saving. It just bumps me to the “All Options” page, and even if I make the changes there…NADA!!

    Help….please…

Viewing 15 replies - 1 through 15 (of 22 total)
  • Are you by any chance running phpMyAdmin on your website?

    If so, great. If not, grab it and you can make the necessary changes to the database directly and fix your issues.

    You will need to edit the ‘wp_options’ field and on the second page, you will find an entry aptly named ‘blog_charset’ that needs to be set to “UTF-8”.

    Hopefully whatever is ailing your blog will be fixed by this change.

    Regards

    *wails*

    Not only can I not make any changes, add/activate/deactivate plug-ins…

    I cannot seem to get the dumb thing to even LOAD… *points*

    It says my config file is wrong???

    OK, got the config issue fixed.

    Got the suggest application uploaded…not sure what to do with it.

    *sigh*

    And all I wanted to do today was post some pictures of my kid. Grrrr.

    Modify the file ‘config.inc.php’ in your phpMyAdmin directory with the necessary database username/password that you have in your ‘wp-config.php’ file.

    Just entering the username and password should be enough. Now when you go to http://yourdomain.com/phpMyAdmin (or wherever you installed it), you will see a nice graphical program. From the drop down menu, choose your WordPress database. You can gather the name from ‘wp-config.php’ again.

    Now, click on the ‘wp-options’ link in the left menu. From there, in the right window click on “Browse” to show you all the information stored in the ‘wp-options’ table. You should now to go the second page using the > button and look for ‘blog_charset’ optionname. Once you find the entry, “Edit” it, make the necessary changes and “Save” at the bottom of the page.

    Hope that gets you going.

    Regards

    Just visited, looks fine to me in FF 1.0.4, no sign of what you describe….

    [Love the 2nd post btw – thankfully I’m all done with that! Some things to be said for aging….]

    That’s strange, I see the problem on FF 1.0.4, Konqueror and Opera under Linux.

    Regards

    Hmm. Yes, that’s odd. The first time I clicked on her link, I got a database error message; just before I posted, I accessed her page for the first time and it’s displaying just fine.

    I just went back, and while the “normal” posts are still displaying fine, the meme she mentions is appearing run together now instead of spaced.

    Strange….

    Nutz

    #2002 – The server is not responding (or the local MySQL server’s socket is not correctly configured)

    I put in the Database username and password

    I’ve got it at:

    http://luckylibra.com/phpMyAdmin-2.6.2-pl1/

    wrong file name?

    I suck…I know…

    I am sorry to be such a n00b

    You should essentially copy over the Username, Password, Hostname into your ‘config.inc.php’. The error message seems to indicate you didn’t provide a password for phpMyAdmin to login to the database.

    Regards

    Thanks Cypher.

    I’ve got the file open in Notepad (didnt know what other program to edit it with).

    Its a huge long mess of coding that is greek to me. I am trying to find all of the places to change my password.

    I know the database name, username, password and host (same info that is in the WP config file). So I am not sure what the deal is.

    You wanna be editing the following three lines:

    On my version of the file (2.6.1-pl3)
    $cfg[‘Servers’][$i][‘host’] – Line 69
    $cfg[‘Servers’][$i][‘user’] – Line 84
    $cfg[‘Servers’][$i][‘password’] – Line 85

    I removed the last entry from my phpMyAdmin configuration and got the same error message as you. So that is most likely the culprit.

    You can leave virtually everything else in the file unchanged.

    Regards

    Another piece of advice, when you are doing fixing your blog with this software, I would strongly recommend either password protecting the directory or removing your username/password from the config.inc.php file. Otherwise, ANYONE can get into the backend of your blog and do nearly anything they want.

    Regards

    I understand…this is all so new to me…I’m on the verge of tears…as silly as that is.

    I think Ive fixed the password issue…now I’ve got a NEW error…

    The host name is empty!
    Warning: Cannot modify header information – headers already sent by (output started at /home/.ballou/luckylibra/luckylibra.com/phpMyAdmin-2.6.2-pl1/libraries/common.lib.php:1388) in /home/.ballou/luckylibra/luckylibra.com/phpMyAdmin-2.6.2-pl1/libraries/select_theme.lib.php on line 98

    Warning: Cannot modify header information – headers already sent by (output started at /home/.ballou/luckylibra/luckylibra.com/phpMyAdmin-2.6.2-pl1/libraries/common.lib.php:1388) in /home/.ballou/luckylibra/luckylibra.com/phpMyAdmin-2.6.2-pl1/index.php on line 55

    Fatal error: Call to undefined function: pma_dbi_get_dblist() in /home/.ballou/luckylibra/luckylibra.com/phpMyAdmin-2.6.2-pl1/libraries/common.lib.php on line 1458

    I think I am gonna scrap it and do a clean install of this admin thing

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Blog Broken’ is closed to new replies.
Skip to toolbar