Support » Fixing WordPress » blog archive appearing on a page as a comment

  • Resolved vicar


    This is just weird. I just made a new post on my site. In addition to appearing as it should, the post is also showing up as a comment on a page…a page that supposedly has the comments toggled off.

    If you want to see it, go to The newest entry shows up as a comment on the WHY blueVicar? page listed in the right column.

    Any ideas about why that would happen? And how I might fix it?….


Viewing 7 replies - 1 through 7 (of 7 total)

    What’s happening is that you linked to that page in another post/page, and wordpress sent a pingback.

    Pingbacks are like comments, except that they appear when people link to a post or page.

    Ooohhh…something new for me! Thank you very much. I never used nor saw what a pingback does. Will this happen to any page that someone pings? Maybe I should make these pages not have pings…

    Just one more thing….is there anyway to get rid of it except to delete the page and start over?

    Thank you again.

    You can delete it from Manage > Comments, in your admin area.

    Deleting the page won’t help, it will happen every time you put a link to one of your own posts/pages in a blog post.

    You can set wordpress to stop pinging posts in the Options > Writing menu.

    Thanks again.

    Could I just ask one more question….since your kind response of earlier I have been reading the Codex documentation about pings, but as I am a bit dense I don’t quite get it. Is it a good idea to allow pings? I should be pinging other sites like ping-o-matic so that they will know that I’ve updated? Do I get a string of these “Responses” everytime someone pings a page?

    Oops, I realize that is more than just one question…sorry.

    Thanks again.

    Right, ‘ping’ is a computing term that means one computer is somehow notifying another computer about something. It’s like a nudge, or tapping someone’s shoulder. So, you ping ping-o-matic when you make a new post, and it tells ping-o-matic that you’ve updated.

    But you can also ping another site to tell it that you’ve written something about it, it’s kinda like a “remote comment” that you can leave on their site. These pings are called pingbacks, trackbacks, or just pings. It’s a good idea to enable pingbacks (I think wordpress calls them trackbacks in the admin area) from other sites (on Manage > Discussion), but you can switch it off for when you make a post (in Options > Writing), and that should speed up posting, too.

    Is that a little clearer, or have I just muddied the waters again? 😉

    Well, there is a small difference between trackbacks (TB) and pings in WP.
    If you link in your posts to a site that is able to receive pings – that goes out automatically.
    To send a TB – you have to put the (other) site’s TB URI into the proper field under your post.

    And back to the original Q: using relative path instead of absolute path in your posts to your own pages/posts, will stop self-pinging.
    I.e. instead of “http ://′ use only “/?p=123” and no more ‘mysterious’ selfpings 🙂

    You guys are great! What an absolutely terrific resource you are to WordPress novices like me. Now I know more new tidbits. I appreciate your patience…and your time. Many, many thanks.:-))

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘blog archive appearing on a page as a comment’ is closed to new replies.