WordPress.org

Support

Support » Plugins and Hacks » WooCommerce » [Resolved] BlockUI alert!

[Resolved] BlockUI alert!

Viewing 15 replies - 1 through 15 (of 32 total)
  • This ^

    I got the same issue here.

    I had this same issue after updating WooCommerce. I reverted back to ver 2.0.5 and I’ll keep it that way until someone can provide a better solution

    Solved.

    1. Go to https://github.com/woothemes/woocommerce/tree/master/assets/js/jquery-blockui

    2. Download the 2 js files. Make sure that the file extension remains as .js after you’ve downloaded them. My firefox turns them into .js.htm files. If that happens, manaully remove the “.htm” in the file name.

    3. Use your ftp or control panel, go into folder where woocommerce stores the 2 js files.
    i.e. wpcontent / plugins / woocommerce / assets / js / jquery-blockui

    4. Backup the 2 files in the folder

    5. Overwrite the 2 files with the ones you just downloaded.

    Refresh you site. The annoying message should go away. 🙂

    Realized that the files for github will somehow cause some problems with the variations in the product post.

    So I loaded back my original backup.

    Edit the 2 original files jquery.blockUI and jquery.blockUI.min by removing the command below in both files (make sure you backup first):

    alert(‘blockUI requires jQuery v1.3 or later! You are using v’ + $.fn.jquery);return;

    Do not delete the {} at the front and back of the command though.

    That stopped the annoying alert on the webpages and then the variations will still work! 🙂

    Until woocommerce come up with a fix….

    I found this article that helped me. Hope it helps someone else.

    http://ideasandpixels.com/blockui-requires-jquery-v1-3-or-later-quick-fix

    I was also getting the BlockUI error after updating to WordPress 3.6, it looks like WooCommerce was the culprit.

    Removing “alert(‘blockUI requires jQuery v1.3 or later! You are using v’ + $.fn.jquery);return;” (but not the “{” or “}” as nonick80 mentioned) fixed it for me.

    The files I needed to remove the line of code from were:

    …/woocommerce/assets/js/jquery-ui.js
    …/woocommerce/assets/js/jquery-ui-min.js

    and

    …/woocommerce/assets/js/admin/woocommerce_admin.js
    …/woocommerce/assets/js/admin/woocommerce_admin.min.js

    Thanks for the tips and I hope my post and the rest here have helped people.

    Can the files be changed to only load on the required pages for WooCommerce and not every page in the admin please.

    Same issue. WooCommerce is the culprit.

    I don’t have woocommerce – and yet still see this error message.

    How do I get rid of it? Just upgraded to WP version 3.6

    Not: Woo Commerce

    And am having trouble identifying which plugin is causing it…

    How do I find it?

    no Woo Commerce here either. Just upgraded WP to 3.6 and get error message
    blockUI requires jQuery v1.2.3 or later! You are using v1.10.2.

    WPyogi

    @wpyogi

    Forum Moderator

    Thank you WPyogi… I did see that post earlier… But, I’m not sure WHERE to replace the jqueryui file…

    Any thoughts?

    I’m getting the same error on the front also. Didn’t notice until just now. So since upgrading WordPress we now have to change a jQuery file. Can’t WordPress just correct this and release a quick update ?

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘[Resolved] BlockUI alert!’ is closed to new replies.
Skip to toolbar